Wifi on but no internet connection? MB pro

Discussion in 'MacBook Pro' started by qqisvip, Aug 13, 2011.

  1. qqisvip, Aug 13, 2011
    Last edited: Aug 13, 2011

    qqisvip macrumors newbie

    Aug 13, 2011
    I have a Macbook pro OSX version 10.6.8. Recently my brother bought an ethernet cable and connected it to his Xbox for XBoxlive. Soon after, my internet stopped working. AirPort says that I am still connected to my Wifi network, but I can't search the web. Additionally, the wifi symbol on the top right corner of my screen has an exclamation mark on it. My router is a Westell Versalink 327W Model# D90-327W15-06.

    On my iPhone4, I am connected to Wi-fi on the same router, and I'm able to access the internet (going on any website).

    These are the resolutions that I tried.
    -Rebooting the router
    -Restarting my MB
    -Manually removing and re-adding the IP address
    -Manually deleting and re-adding the IPv4 Address, Subnet Mask and Router.
    -Manually deleting and re-adding the DNS server and Search Domains.
    -Removing ethernet cable from xbox and from router

    How can I fix this "wifi on, but no internet" problem?
  2. skiltrip macrumors 68030

    May 6, 2010
    New York
    This happened to me today after I had plugged my Ethernet into an Airport Express to configure it.

    Just add a "new" network, choose your router and re-enter the password. That's what worked for me.
  3. qqisvip thread starter macrumors newbie

    Aug 13, 2011
    It doesnt work. I ran my diagnostics and this is what came up on my Network status:

    Airport: Green
    Airport settings:Green
    Network settings: Orange
    ISP: Green
    Internet: Red
    Server: Red

    I might have to call my ISP and see what's going on.
  4. jrfive0 macrumors member

    Mar 22, 2011
    OP: did you find a resolution or the cause of the problem? I'm having the same issue :confused:
  5. Adamantoise macrumors 6502a

    Aug 1, 2011
    As am I.

    I notice that turning Wi-Fi off and turning it on again fixes the problem.

    However, the problem resumes the minute you wake the computer from standby/sleep.

    Very irritating problem.
  6. MacNOW2 macrumors newbie

    Dec 23, 2011
    self assigned IP

    OK, had the same problem, here my fix:
    Check Keychain and delete the Network you want to connect to. Then start again and hopefully it will work without any problm :D
  7. Bazza90036 macrumors newbie

    Apr 3, 2013
    Just figured it out....it's the Airport Password

    Was having similar problems to the above thread. Wifi Network was showing it was connected but I could not connect to Internet. Airport Extreme was flashing AMBER.

    Modem signal was fine.
    Network Prefs showed:

    Airport: Green
    Airport Settings: Green
    Network Settings: Green
    ISP: Green
    Internet: RED
    Server: Red

    After checking with ISP and connecting to the internet via Ethernet my ISP told me that there was something wrong with my wireless router (the Airport Extreme).

    I ran Airport Utility and and it came back reporting problems.

    (IMPORTANT: A few days earlier I had re-set my email password.)

    As soon as I updated my "new" password in the Airport Utility...the airport restarted and I was good to go.

    It was as simple as entering my new password!!

    Hope that helps!!

Share This Page