Wifi Password accepted but internet not working

Discussion in 'iPhone' started by raziiq, Jul 23, 2009.

  1. raziiq macrumors member

    Joined:
    Aug 26, 2008
    #1
    Hi there.
    When i connect to my Wifi, it asks for the password, i input the password which is accepted and a tick mark is there in front of the Wifi name under settings but when i open safari or youtube or weather or stocks, the internet is not working.

    Any suggestions??
     
  2. Titan12 macrumors regular

    Joined:
    Jun 16, 2009
    #2
    We may need a little more info about your router. What kind is it? And how old is it? Is there a chance that it is broadcasting in A instead of B or G? I ran in to this issue at a local establishment. The router was simply too out of date to use with my phone. Also, have you verified that other devices work with the router?
     
  3. Elementkng20 macrumors member

    Joined:
    May 28, 2009
    #3
    Sometimes the router could only accept the device if the mac address is entered into the router configurations. Putting in the password may accept it, but it also may need the mac address into the router. Or it could be case sensitive. Like the previous post too, it may be too old for the iPhone.
     
  4. raziiq thread starter macrumors member

    Joined:
    Aug 26, 2008
    #4
    it is broadcasting B, G n N , so the router is new. Its working fine with my Laptop but then its not working on my friend's laptop, dont know why?

    BTW what do you mean by entering the MAC address in iPhone??
     
  5. Elementkng20 macrumors member

    Joined:
    May 28, 2009
    #5
    Settings-General-About

    Look at the bottom It's called the Wi-fi address in iPhones. Each device has a Mac address. For a more secure connection for computers or iPhones, you can add the Mac address into the router so even though the password is accepted, the router still needs the Mac address to make it work.

    It just may be case sensitive. Or the settings for the laptop aren't configured right.
     
  6. raziiq thread starter macrumors member

    Joined:
    Aug 26, 2008
    #6
    is that if the passwords are case sensitive, even then iPhone will accept the password?? Also is it there any case that if we dont enter MAC address into our iPhone, the Wifi is still shown connected but router will not send data to the device?
     
  7. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #7
    I'd suggest that you log into your router and see if it shows the iphone connected. See if the router's own logs report any problems.

    Also, see if your iPhone actually has been assigned an IP address in wi-fi, under Settings, wi-fi
     
  8. sammy2066 macrumors 6502a

    Joined:
    Oct 3, 2007
    #8
    There could be a couple of issues here.

    1) Is the connection working on another laptop or desktop? Then the problem might be in your iPhone.

    2) Check if the router is configured to assign IPs via DHCP. From your iPhone, try renewing the lease while under the DHCP tab.

    Let us know how it goes.
     
  9. richardhunt macrumors regular

    Joined:
    Oct 2, 2007
    #9
    If the iphone has a valid DHCP assigned address and it still doesn't work, then try to reset your network settings in your iphone. This has happened to me a couple of times. If the ip address is not a valid address, then it's a problem with your router's configuration.
     

Share This Page