wifi problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by zoheb, Aug 25, 2009.

  1. zoheb macrumors newbie

    Joined:
    Aug 25, 2009
    #1
    i have an IPHONE 3G unlocked. . the wifi worked fine when i updated to the 3.0
    but since yesterday the error comes up saying
    UNABLE TO JOIN THE NETWORK "..........."

    i tried resetting the network settings, turning off and on the phone a couple of times but no use. .. and i was able to give FORGET THIS NETWORK before..
    but now all it shows is

    UNABLE TO JOIN THE NETWORK "............"

    what to do ??
    :(
    thx
     
  2. iOrlando macrumors 68000

    Joined:
    Jul 20, 2008
    #2
    well since you didnt include this...

    check to make sure other wifi devices can get a signal.

    if they cant either..just unplug your router and plug it back in.

    alot of times..the problem is with the router and not the iphone.
     
  3. zoheb thread starter macrumors newbie

    Joined:
    Aug 25, 2009
    #3
    well the wifi works on a laptop and as well works on a HTC phone with out any problem.

    all of a sudden the wifi stoped working on the iphone.
    some times it shows UNABLE TO JOIN NETWORK. or some times it shows its connected but if i try to access it. like use safari or check the weather.. it looses the connection and i have to do it all over again ..
    what could be the problem?
    please i need help..

    and i have a beetel 250 BXI (airtel) modem
    thx
     
  4. RichardZA macrumors newbie

    Joined:
    Aug 26, 2009
    #4
    There is a growing number of iPhone users who are having WiFi problems since 3.0. Issue range from terrible signal to WiFi that is completely dead - myself included (I can't see ANY networks).


    A huge thread (760+ replies) on Apple's forums has hundreds of iPhone owners complaining about it.

    It seems to be related to the 3.0 update. Those who have taken their phones to an Apple Store are given a replacement phone (if still in warranty), so it seems like a possible hardware fault, although many people think that OS 3.0 is somehow frying the WiFi chips.

    We're trying to get Apple to officially respond to/acknowledge the problem.

    EDIT: If you too are having WiFi problems since 3.0 PLEASE go and add your voice to the Apple thread , the more people that post their problems there the sooner Apple will hopefully respond.


    @zoheb: Have you tried:
    A) Settings->General->Reset->Reset networking Settings
    and if that doesn't work
    B) Restoring your phone through iTunes?
     
  5. zoheb thread starter macrumors newbie

    Joined:
    Aug 25, 2009
    #5
    i cant give my phone to the apple store cause iv jailbroken it.
    and i dont have the warrenty either.

    iv tried resetting the network but that helps show the network but i cannot access any thing

    wont restoring iphone throught itunes rease all the data?
    but i havent tried that option yet

    i updated to the 3.o just 2 weeks after it released. so its been a while since using the os 3.o

    does this have to do any thing with the MAC FILTER at the modem settings?
    cause for me i saw it showed DISABLED. if i gave enabled it asks for mac address


    :)
     
  6. RichardZA macrumors newbie

    Joined:
    Aug 26, 2009
    #6
    When you do a restore through iTunes it will give you the option to restore from a backup.I'm not exactly sure how the restore will affect your jailbreak though, but I suspect it will 'unjailbreak' it and you will lose any jailbroken apps (& their data).

    If the MAC filtering is disabled then it shouldn't be a cause of this problem no, but if it was enabled and you hadn't added your iPhone's MAC address to the modem's list of allowed MAC addresses then it would cause problems.
     
  7. bki122689 macrumors 6502

    bki122689

    Joined:
    Sep 18, 2008
  8. zoheb thread starter macrumors newbie

    Joined:
    Aug 25, 2009
    #8
    i dont mind loosing the 3rd party applicaiton and its data.. thats what happend when i updated to the 3.0

    the phones wifi worked fine even after updating to 3.0 untill a few days ago

    where can i find the iphone's mac address?

    i have 2 modems at home and the iphone does not connect to both the modems. so i suspect its got to do some thing with the iphone settings..
     
  9. orionpower macrumors member

    Joined:
    Oct 1, 2007
    #9
    Did you try to logon like say at tht local starbucks coffee to see if its your networks or the phone.
    you can find the setting--> general ---> about --- wi-fi add.
     
  10. zoheb thread starter macrumors newbie

    Joined:
    Aug 25, 2009
    #10
    well we dont have starbucks in this city..
    but i could try at a libarary or some other cafe..

    yesterday the wifi did not get connected at all. but today it gets connected and the signal comes up strong . the signal shows for like a 30 seconds and turns back to "E"(EDGE which is not connected)

    and when the signal is up and i try to access like check weather. it turns back to "E"(edge which is not connected)

    oh and some times it came up saying im not connected to a cellular network

    thanks appricate any help
    :)
     
  11. WickedRabbit macrumors regular

    Joined:
    Feb 17, 2009
    #11
    Ignore iOrlando entirely and listen to Richard. There is definitely a problem with OS 3.0. Also, exchanging the phone may or may not do anything, as I did an exchange (also because I was having a few other issues) and the Wi-Fi problem still exists. It will randomly disconnect, randomly reconnect, say "unable to connect", "incorrect password out of nowhere" and then automatically reconnect itself. It does this every single day and I have yet to go a single day with a solid wi-fi connection.

    It's not your router, especially as you mentioned everything else is connected fine without a single problem (same here). Unfortunately, at this point it looks like we're just going to have to wait for a software update to fix it.

    But yea, it's definitely an annoying factor, especially when you're downloading something and the wi-fi connection times out and sort of crashes your app since the iPhone can't seemlessly switch from network connection to wi-fi or vice versa.
     
  12. zoheb thread starter macrumors newbie

    Joined:
    Aug 25, 2009
    #12
    hmmmm atleast for one of the modems it shows conencted on the iphone. but cannot access.. and other doesent show at all

    i still have the option of resetting all the data from settings<reset

    and the option of restoring the iphone from its back up throught itunes

    but im just holding back because my phone is jailbroken. i went throught a lot to update the phone to 3.0

    :)
     
  13. niuniu macrumors 68020

    niuniu

    Joined:
    Mar 29, 2009
    Location:
    A man of the people. The right sort of people.
    #13
    I updated the 3.0 last week and I don't get wifi anymore either, it just doesn't detect any networks.
     
  14. zoheb thread starter macrumors newbie

    Joined:
    Aug 25, 2009
    #14
    well people im going to try restoring the iphone from backup throught itunes

    i will loose the jailbreak
    but the phone will still be unlocked..

    hope the wifi works
     
  15. niuniu macrumors 68020

    niuniu

    Joined:
    Mar 29, 2009
    Location:
    A man of the people. The right sort of people.
    #15
    Tried it, twice. First restore to 'my name', then second restore to new iPhone.

    Neither brought the wifi back..Going to get the gf to take it to a genius guy in a couple of weeks - no Apple store anywhere near where I live unfortunately.
     
  16. zoheb thread starter macrumors newbie

    Joined:
    Aug 25, 2009
    #16
    hmm i tried restoring from backup and that didnt work
    i can try just giving restore but worried
    cause my phone is unlocked and jailbroken
    so if i restore it would try to update the phone and the phone can get bricked

    any suggestions people?

    i cant take my phone to the apple store.. cause i dont have the warrenty either
     
  17. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #17
    I hate to say it

    but you might have to wait till 3.1 comes out but I will guess another month maybe longer till there is a jailbreak out for it. you could try downgrading to 2.1 see if that fixes it. I helped a guy Jailbreak one with this issue I got around it by using my At&T sims card to get ultrasn0W from Cydia etc. afraid there aren't many options
     
  18. zoheb thread starter macrumors newbie

    Joined:
    Aug 25, 2009
    #18
    thanks for your help guys.. but im afriad the wifi isnt working

    as i said earlier that i have 2 wifi connections at my house and the iphone does not get connected to both the wifi's

    today i tried the wifi at my cousins house and no connection appeared on the iphone
    :(

    my cousin also has the same airtel 450 BXI modem as me
     
  19. loskickking23 macrumors 6502a

    Joined:
    Jun 13, 2008
    #19
    My phone is showing that it is connected and just won't work....it says connecting in the middle of my screen and then nothing...Soon as I switch off wifi and use 3g I'm fine...BTW my phone is jailbroken...I don't know what else to try...It was fine until I added 3g restrictor ...does anyone know what else I can try if its showing that it's connected?
     
  20. dn325ci macrumors newbie

    Joined:
    Mar 13, 2009
    #20
    My wife is using a 2G and I have a 3GS. Both are OS 3.0. The 2G holds a solid wifi signal. The 3GS is unbelievably, frustratingly flakey. It cannot hold a consistent wifi signal at home to save it's life. The 2G is rock solid. Outside of the home, the 3GS occassionally seems better on some access points than others. I don't know why.

    Don
     
  21. gloc9 macrumors newbie

    Joined:
    Sep 1, 2009
    #21
    I have the same problem with the wifi.. "unable to join the network" or in other wifi areas, where wifi is detectable but cannot acess to safari or internet related programs/applications.. I'm not using OS 3.0 but version 2.2

    another thing, my itunes cannot seem to detect the iPhone. My iTunes only detects my iPod.. how can I sync my phone if the iTunes cannot detect it???
     
  22. Ntombi macrumors 68030

    Ntombi

    Joined:
    Jul 1, 2008
    Location:
    Bostonian exiled in SoCal
    #22
    I had exactly the same problem you described, OP, except my 3GS could connect to other networks, just not my own. It's extremely frustrating.

    I took it to the Apple Store and got a replacement on Saturday. The new phone has the same problems! :mad: I went back to the Apple Store today, and the Genius I got today was less helpful. Because my iPhone could connect to the Apple Store wifi, he felt like maybe the problem is with my new Time Capsule. I had thought so too, since the problem started when I switched to it from an older Belkin. But every other device connects and keeps the connection without a problem. So now I have to bring in the Time Capsule for a swap. :rolleyes:

    I'm very frustrated, because I got my 3GS on launch day, but this problem just started last week, and it's hard to show the problem. I took a bunch of screenshots of "unable to find network," "unable to connect to network," full lines of wifi, one line of wifi, endless "connecting," etc. all within a minute or two, to no avail.
     

Share This Page