Wifi problems 10.9.4

Discussion in 'OS X Mavericks (10.9)' started by Carlos840, Jul 7, 2014.

  1. Carlos840 macrumors member

    Joined:
    Nov 5, 2013
    #1
    Hi,

    Since updating my 2009 imac from 10.9.3 to 10.9.4 i am having a weird wifi problem.
    Sometimes when waking up from sleep the imac will not automatically connect to my regular wifi but to some random other wifi.

    If i try to select my regular wifi it will not recognise my password, saying "password incorrect" although it is correct. I can try turning wifi on and off, anything, nothing works.

    The only way i can get the imac to connect to my regular wifi is to reboot both the imac and the wifi modem.

    When i do that, the imac recognises it and connects to it fine, without even asking for my password.

    It does that maybe one out of 5 times when waking up from sleep.

    This never happened once on 10.9.3

    "automatically join this network" and "ask to join other networks" are both selected, it still does it.

    Any ideas?
     
  2. wuush macrumors member

    Joined:
    May 4, 2014
    #2
    maybe you could try to remove everything or just the wireless network in question from your wireless network preferences and add it again.
    Maybe changing your network priorities might also help.
     
  3. Carlos840 thread starter macrumors member

    Joined:
    Nov 5, 2013
    #3
    I think i found the problem, for some reason two other random WIFI had been added to the "preferred networks" list, i deleted them and it hasn't happened since.

    No idea why it did this and why it only started happening after updating to 10.9.4, but it it did.
     
  4. Carlos840 thread starter macrumors member

    Joined:
    Nov 5, 2013
    #4
    Well, it still does it, but instead of trying to join some random other WIFI it just says "the preferred wifi is not available".
    The network works fine because i can access internet with my iPod touch, but the iMac refuses to join, and still tells me my password is incorrect.

    Only thing that cures it is to reboot both the iMac and the modem.

    This is really annoying, any ideas?
     

Share This Page