Wifi problems - latest version of Leopard on iMac

Discussion in 'iMac' started by michaelb19, Jan 10, 2010.

  1. michaelb19 macrumors newbie

    Joined:
    Jan 10, 2010
    #1
    Hello all,

    I've had an iMac for 8 months now, and I have recently bought a new router as my previous one died after 3 years of service and so I got a new one from BT (I'm in the UK). The new router works with 3 laptops, an iPhone, and two desktop PCs - but not with my iMac.

    It intermittently picks up the signal and when it does finally connect, says the router is not connected to the internet - despite my laptop and iPhone being on the same desk and connecting.

    I even moved the router to within 5 feet (the closest possible with the locations of my phone ports) and it doesn't work (my laptop and iPhone still do).

    Yet if I move my iMac downstairs it does work.

    This may seem like an obvious location issue, yet i don't understand why it works in one location and not another?

    Would using an ethernet cable direct from the router be the best thing to do?

    OR are there other ways to configure the iMac to pick up the signal?

    I'm at a loss of other options so any help would be greatly appreciated.

    Thanks alot,
    Mike
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Try it with Ethernet cable and see if that helps
     
  3. michaelb19 thread starter macrumors newbie

    Joined:
    Jan 10, 2010

Share This Page