Wifi Problems Still!!!

Discussion in 'iOS 6' started by mkd79, Sep 18, 2012.

  1. mkd79 macrumors newbie

    Joined:
    Sep 18, 2012
    #1
    I could not wait for iOS 6 to come out as I thought they would fix the bugs that so many people are having.....but no!! :0(

    Things include:

    1. You wifi network settings don't save and therefore you have to type it in each time. You know this is not saved when once entered if you use the arrow next to it the "Forget this Network" button is not present.

    2. You cannot connect at all to a router.

    I upgraded to 5.11 and was fine for a while then one day the above started to happen. Tried several scenarios and have tested on old G wirless networks and has no problems but seems to be N wireless routers I have problems with. I can make it save and connect to one by adding all info manually but another one at work I can't access this way at all.

    What's everybody's comments??
     
  2. pugnut macrumors 6502a

    Joined:
    Jul 1, 2007
    #2
    I am having zero issues with wi-fi or router connections. Have not since beta 3
     
  3. ReValveiT macrumors regular

    Joined:
    Sep 20, 2012
    #3
    Having exactly the same problems OP (iPhone 4).

    Strange thing is, 'Forget This Network' was there last night AFTER the IOS6 update as I used it during the 'apple.com' wifi issue last night. Now it's vanished into thin air.

    "It just works" ... No it doesn't.

    Surely we can't be the only ones?
     
  4. Flat Six macrumors newbie

    Joined:
    Jul 14, 2012
    #4
    Weird wifi problem here. Both iPhone 4s and iPad 2 upgraded to iOS6. My network has two AE's to cover my apartment. The iPad doesn't have a problem, I have great wifi reception everywhere.
    But the iPhone doesn't connect to the extended AE. No wifi here. And the AE is working fine, I see it on the iPad and the iMac.
    Last night I did a reset on de AE and configured it again. It seemed to work, I had wifi on the iPhone. But this morning the problem was there again. And another reset didn't work.

    Something is still not working properly.
     
  5. ReValveiT macrumors regular

    Joined:
    Sep 20, 2012
    #5
    Yep,

    If I let my iPhone sleep for a few minutes, I have to re-enter my wifi password on wake otherwise it just stays at 3G.

    If I go in and turn wifi off and back on again, it forgets my password again.

    5.1.1, I miss you...
     
  6. ReValveiT macrumors regular

    Joined:
    Sep 20, 2012
    #6
    Ok!

    I renamed my routers name (SSID) and that's fixed it. 'Forget This Network' is back and it automatically re-connects from sleep without having to input the password every time.

    Looks like the iPhone had a strange glitch with my router and its saved settings.
     
  7. Nighttracker macrumors member

    Joined:
    Feb 24, 2012
    #7
    Same problem here. Updated the ipod 4g and the new iPad last night to ios6 and both wifi's won't stay connected longer than a few seconds.

    I have 2 very expensive coasters right now...sucks!!
     
  8. bender0069 macrumors member

    Joined:
    Jul 15, 2007
    #8
    I agree, I hate having to go into setting and telling my phone and my ipad to join my network everytime the device goes to sleep. This needs to be fixed asap
     
  9. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #9
    You might check your router/access point and ensure that Wi-Fi MultiMedia (WMM) is enabled. It seems that iOS 6 requires that (WMM) be enabled. :(
     
  10. mkd79 thread starter macrumors newbie

    Joined:
    Sep 18, 2012
    #10
    Yes I have tried disabling WMM and then re-enabling with no difference.

    However I found something interesting. I disabled any encryption on my wireless and it still did not connect at all. I then change my SSID from the default "NETGEAR" to say "NETGEAR1" and both encrypted and non encrypted wireless worked. Then removed those networks from my phone and changed the SSID back to "NETGEAR" and neither worked again. I have always had the default SSID from day 1 as most have BT Hubs.
    It is like the file within the iPhone software that stores the wifi info is corrupt. When doing an upgrade etc. this file has old info kept and it does not refresh or update for a particular SSID name.
    Does anyone know the file this is kept in and how to access it???? and either edit or replace.

    What your thoughts?????
     
  11. davelanger macrumors 6502a

    Joined:
    Mar 25, 2009
    #11
    Did you try clearing your cache and internet history? Also reset network settings
     
  12. mkd79 thread starter macrumors newbie

    Joined:
    Sep 18, 2012
    #12
    Yup done all that and think my theory is right??

    What you think???
     
  13. Yester5 macrumors regular

    Yester5

    Joined:
    Nov 26, 2009
    Location:
    Pittsburgh, PA
  14. mkd79 thread starter macrumors newbie

    Joined:
    Sep 18, 2012

Share This Page