Wifi problems with 3.0

Discussion in 'iPhone' started by jamesapp, Jun 25, 2009.

  1. jamesapp macrumors 6502a

    Joined:
    Mar 7, 2008
    #1
    I just recently updated my 3g iPhone to the 3.0 firmware. I was testing out a couple of apps that use wifi, remote and wifi track(I think it is called wifi track). The remote app ,I downloaded the latest 3.0 compatible version, from the AppStore. When I went to use remote, I created an ad hoc network on my laptop, it worked for a little while but then the app stopped controlling iTunes and said I needed to be on wifi. The wifi track app when I opened it gave me an error message saying: unable to initialize wifi scanner. I am just wondering if there is something wrong with either the apps or the wifi on my phone. Also wondering if anyone else had a similar problem, or if anyone could help me fix my problem?
     
  2. Espo macrumors 6502

    Joined:
    Aug 16, 2007
    Location:
    NY
    #2
    , too, have been having wifi issues. Sometimes my phone won't pick up Wifi or takes a minute to pick it up. I'm taking it to the genius bar soon.

    Try resetting your network settings.
     
  3. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #3
    I can confirm wifi is a bit shakey on OS 3.0.
     
  4. MBHockey macrumors 68040

    MBHockey

    Joined:
    Oct 4, 2003
    Location:
    New York
    #4
    Definitely something wrong with wifi on 3.0. 3g and 3gs both show weak signals 10' from router.
     
  5. Sledutah macrumors regular

    Joined:
    Jun 15, 2009
    Location:
    Utah
    #5
    My 3gs wifi sucks bad, so slow I can't use it. I've sent emails to Apple, but haven't heard anything. I'm sure it has to do with 3.0 and not a hardware issue.
    http://www.apple.com/feedback/
     
  6. jamesapp thread starter macrumors 6502a

    Joined:
    Mar 7, 2008
    #6
    Ok, just got back from the library where they have wifi and my wifi on my phone worked. I was able to connect and stay connected. I just got home and created an ad hoc network on my laptop and when I went into settings on my phone my wifi disconnected a couple of times. I reset my network settings and when my iPhone restarted I went into settings connected to my ad hoc network and my wifi disconnected again. I am using a MacBook pro laptop, one thing is a couple of days ago I ran some updates on my laptop, I am pretty sure airport was one of the updates. Also wifiTrak came out with an update for 3.0 so I am going to test that app again.
     

Share This Page