Wifi problems with all my devices

Discussion in 'Mac Accessories' started by adejesus, Apr 16, 2015.

  1. adejesus macrumors newbie

    Joined:
    Aug 20, 2011
    #1
    I just moved into a new apartment that includes free wifi internet. The free wifi was too slow so I opted to get my own direct internet. I'm using the same Linsky router form my last place with a cable modem. The problem I am having is even after telling all my devices (mbp, 3 iPads, 2 iPhones and some non Apple devices) to forget the free network they keep either going back on to that network or my router is constantly dropping out. It may be my router but it's odd I've never had this problem until I had access to my own network and two free networks. Any suggestions on trying to figure out how to get this problem solved?
     
  2. infantrytrophy macrumors regular

    Joined:
    Oct 27, 2013
    #2
    You may be dealing with the typical apartment "crowded networks" problem, or too many wifi networks trying to use the same 2.4-GHz channels. The primary causes of wireless LAN problems in high-density areas are:
    1) Too many users trying to use the same channel.
    2) RF (Radio Frequency) interference from nearby WLANs
    3) Improper wireless adapter settings

    Try changing your router's wifi channel to one that is less crowded, or better yet, to a 5-GHz channel (assuming you have a dual-band router).

    Here are a some places to start reading about this:

    http://www.smallnetbuilder.com/wireless/wireless-howto/31656-it-takes-a-neighborhood-to-fix-bad-wireless

    http://www.smallnetbuilder.com/wireless/wireless-howto/31190-when-wireless-lans-collide-how-to-beat-the-wireless-crowd

    http://www.smallnetbuilder.com/basics

    http://www.networkworld.com/article/2167574/smb/10-biggest-home-networking-mistakes--and-how-to-fix-them-.html
     
  3. adejesus thread starter macrumors newbie

    Joined:
    Aug 20, 2011
    #3
    Awesome thank you for the links. I will start reviewing these tonight after work.
     
  4. infantrytrophy macrumors regular

    Joined:
    Oct 27, 2013
    #4
    Forgot to mention -- you are much better off using your own LAN (local network), secured with a secure password using the WPA2 protocol, behind your own router. Your apartment's "free" wifi is essentially a public network. Do whatever it takes to get your own network working so you don't have to use a public network.
     
  5. adejesus thread starter macrumors newbie

    Joined:
    Aug 20, 2011
    #5
    I am currently using my own WPA2 with on router but my devices keep syncing to the free wifi if that's not happening my router keeps dropping out and I have to reset it.
     
  6. infantrytrophy macrumors regular

    Joined:
    Oct 27, 2013
    #6
    You'll have to figure out why your devices preferentially connect to the free wifi. It could be that the signal is stronger, or there is interference or congestion on the channel that your router is using. Or maybe there is something wrong with your router setup. Hard to say from here. :confused:

    First, read one or two of the articles to get an understanding of the various channels available on the 2.4GHz and 5GHz bands. Make sure that you know how to set up your router - usually you have to use a web browser and type in the IP address 192.168.0.1 or 192.168.1.1, something like that, so take you to the router setup page.

    Then use the Mac's built-in wifi diagnostics to look at the available networks ---> Hold down the <option> key and click on the wifi symbol (one of the symbols or icons at the very top of your screen, near the right side. It looks like a fan with curved lines, coming to a point at the bottom.). You will see a drop-down of the available networks with the channel number and signal strength (RSSI number, the smaller the absolute value of the number, the better) of each network. For the networks that you are not connected to, just "hover" the cursor over the network to see that network's information. You can disconnect from the apartment's free network and join the one that you choose.

    Now that you can see the available networks, you might get an idea of what the problem is. If you see a bunch of networks all broadcasting on channel 6 (or 1 or 11), for example, you should avoid that channel. You can then go and set up your router to broadcast on a vacant channel (or the least crowded channel). For the 2.4 GHz band, technical issues indicate that you should use band 1, 6 or 11 (read the articles). There are more choices, or you can just use automatic setup, for the 5 GHz band. In your router setup, choose a name for your network (so-called SSID) that you will recognize (You can use "adejesus' network", for example). Then set up wifi in your devices to connect to that network and to avoid the apartment's free wifi.

    Depending on your situation and how congested your wi-fi network environment is, it might be worthwhile to buy a dual-band router that has both 2.4 and 5 GHz bands. (This assumes that your devices are capable of using the 5GHz band, of course). The 5GHz band is usually less crowded because the standard is newer and most people don't know enough or don't bother to move to the 5GHz band.
     

Share This Page