Wifi problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jonakin, Dec 22, 2010.

  1. jonakin macrumors newbie

    Joined:
    Jul 9, 2008
    #1
    Hi, i just got an ipod today and i have some wifi problems. I cant sign into game center or mail or anything that requires an internet connection. it just loads for ages but i still usually have 3 bars.
    for some reason youtube and google maps works perfectly.
    anyone know whats wrong?
     
  2. b0blndsy macrumors 6502

    Joined:
    Nov 9, 2010
    Location:
    Illinois
    #3
    Try Reset Network Settings or update the wifi router.
     
  3. jonakin thread starter macrumors newbie

    Joined:
    Jul 9, 2008
    #4
    I've restored it and updated to 4.2 and there's still problems. Any other suggestions?
    thanks
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    When you restore make sure you pick setup as new. Dont restore from any of your backups cause it might be buggy.
    If you restore again and setup as new and still does the same I'd bring it to Apple.
     
  5. jonakin thread starter macrumors newbie

    Joined:
    Jul 9, 2008
    #6
    Ok, I think its my router thats causing the problem because when i use my macbook as a wireless router the ipod can connect it to perfectly but when i connect to the router it doesnt work.
    I've the router on wpa2 psk or something, I changed it to wep but it didnt work.
     

Share This Page