Wifi problems

Discussion in 'OS X Yosemite (10.10)' started by sallirawr, Jul 4, 2016.

  1. sallirawr macrumors newbie

    Joined:
    Jun 12, 2009
    #1
    Hi all.

    I have a MacBook Pro, Yosemite OS. I have an ADSL router.

    My wifi isn't working on any of my devices and so I know my MacBook is not the issue here but didn't know where else to post. The devices connect to the wifi but the internet doesn't work.

    My router has been playing up lately and I've had to switch it on and off in order for it to work. It stopped working again today and so I turned it on and off but this time, it didn't work. Not only that, but my WEP password magically disappeared and so the network was no longer security coded without me even doing anything myself.

    I've tried everything. Un plugged the router, restarted my devices, etc etc. On system preferences under Network, I've tried adding new locations but again to no avail. For the record, network diagnostics shows the following:

    Wifi GREEN
    Wifi settings GREEN
    Network settings GREEN
    ISP GREEN
    Internet RED Failed
    SERVER RED Failed

    I've looked at the advanced tab and TCP, DNS etc looks as it should. Please can someone help me? :(
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Either your router has died, or there is a problem with your ISP. The first thing to do is to see if you can connect with a device plugged directly into your modem with ethernet. If you cannot, then call your ISP.
     

Share This Page