Wifi problems

Discussion in 'Mac Basics and Help' started by serigraph73, Feb 14, 2010.

  1. serigraph73 macrumors newbie

    Joined:
    Feb 14, 2010
    #1
    Hi. I am new. This is my first post. I came here and tried searching for what I am having a problem with, but didn't find anything right away, and unfortunately do not have the time to weed through the many, many posts here, so I am hoping someone can help me out. I will try to provide as much info as possible

    Scenario:
    Originally had Airport Extreme wifi basestation. I am running on old iBook G4 with OS 10.3.9 and a newer MacBook Pro with OS 10.6.2. My girlfriend has a PC laptop. Before i got the Macbook pro, i had no security set on the base station because i needed OS 10.4, then my g/f moved in and we set up the airport extreme base station security up on her pc. Everything worked fine until i brought home the MacBook Pro. suddenly, My iBook would not get a signal at all, and i was having problems with the MacBook Pro. My girlfriend, however, could still get a signal, no problem. There was an airport update for mac, so i updated and then thats when i couldnt get a signal AT ALL. I couldnt figure out what the deal was and got fed up and went and bought a Netgear wifi router. I set it up on my g/f's PC again, since there was a set up wizard. I wanted to set it up on my MacBook Pro, but it was so complicated that I didn't even want to attempt it.

    NOW, starting a couple of weeks ago, my browser started lagging and it was taking longer than normal to download/upload etc. I saw that once again, there was an update for airport. I held off updating for a while because i didnt want it to hose my whole Wifi deal again. But alas, i got sick of everything lagging, and bit the bullet hoping it would take care of the problem. So, i did the update, logged into Netgear's website, via my g/f's PC andran updates on the wifi router itself, and now she cant get a signal, my iBook G4 will not get a signal and gives me an error, and my MacBook Pro will get a signal and load web pages but it literally takes FOREVER. I logged into my yahoo email account and could never get it to load up my inbox.

    I am not tech savy at all and do not know how to manually set up any of this stuff, but i am thinking that's the only thing that may solve it (other than hardwiring into the router). I don't want to hardwire as a permanent fix, because I use both of my computers for my home business and need the wifi, as does my girlfriend.

    Can anyone help at all? I am about to go out of my mind...

    Thank you!!!
     
  2. chrismacguy macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #2
    Have you tried restarting the Router, and also looking in System Preferences>Networking on the Macs to see if theyve actually lost some settings (I had a similar issue on my 10.5.8 PowerBook when it lost some of the info in there)
     

Share This Page