iPhone WiFi randomly disconnect

coldwaves

macrumors 6502
Original poster
May 30, 2011
322
48
iPhone XS on iOS 13.5.1. Recently, WiFi starts to randomly disconnect. Turnning off WiFi and immediately turning it back on solve the issue. My two laptops use the same WiFi and does not have this issue. I haven't used the iPhone on other WiFi since I have been working from home. Has anyone else encountered this issue?
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,398
17,012
iPhone XS on iOS 13.5.1. Recently, WiFi starts to randomly disconnect. Turnning off WiFi and immediately turning it back on solve the issue. My two laptops use the same WiFi and does not have this issue. I haven't used the iPhone on other WiFi since I have been working from home. Has anyone else encountered this issue?
Unfortunately likely won't be helpful, but I'm having pretty much the same experience with my MacBook. It's kind of an oddity that I haven't been able to figure out.
 

coldwaves

macrumors 6502
Original poster
May 30, 2011
322
48
I have seen on Reddit that disabling WiFi assist might help. I tried but it does not seem to help.
 

AbielM16

macrumors regular
Sep 30, 2019
144
72
I believed I solved our issue and its going to be hard to believe; but it seems to be the router alone and mac address. Test this out just either restart the router and see if your issue goes away for the phone. I believe its a mac address problem and it would probably be as simple as that. At first I tried restarting my iphone x ios 14 but it seems to be just the router just not wanting to connect to a device with same mac address but seems new to it
 

coldwaves

macrumors 6502
Original poster
May 30, 2011
322
48
I believed I solved our issue and its going to be hard to believe; but it seems to be the router alone and mac address. Test this out just either restart the router and see if your issue goes away for the phone. I believe its a mac address problem and it would probably be as simple as that. At first I tried restarting my iphone x ios 14 but it seems to be just the router just not wanting to connect to a device with same mac address but seems new to it
I have tried restarting the router but it does not resolve the issue for me. Maybe I should try to reset the router to factory default to see if that helps.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.