Wifi recognized by iphone but doesnt work

Discussion in 'iPhone' started by mathewr, Feb 22, 2008.

  1. mathewr macrumors 6502

    Joined:
    Sep 14, 2007
    #1
    Hi, at home the iphone recognizes the wifi connection by showing the wifi signal instead of the E for edge but when i go to safari it doesnt work. My mac uses wifi and it works fine. does anyone know how to fix this.

    thanks in advance
     
  2. MrT8064 macrumors 6502a

    MrT8064

    Joined:
    Jun 7, 2006
    Location:
    UK
    #2
    you could try manually setting an IP address.

    sometimes my iPhone does the same; in my experience it seems to fix its self!
     
  3. Pennine macrumors 6502

    Joined:
    Jan 17, 2008
    Location:
    Glossop UK
    #3
    Yeah that happens to me does it go back to E when you open safari ?
     
  4. Pennine macrumors 6502

    Joined:
    Jan 17, 2008
    Location:
    Glossop UK
    #4
    How ?
     
  5. mathewr thread starter macrumors 6502

    Joined:
    Sep 14, 2007
    #5

    nope it just stays there and when i go to wifi connections through settings it has the check mark next to my network
     
  6. Pennine macrumors 6502

    Joined:
    Jan 17, 2008
    Location:
    Glossop UK
    #6
    same here
     
  7. iHerzeleid macrumors 6502a

    iHerzeleid

    Joined:
    May 5, 2007
    #7
    That only happens to me when there is no present internet connection on the WiFi network.
     
  8. jimhanika macrumors newbie

    Joined:
    Jun 3, 2006
    Location:
    London
    #8
    wifi at odds

    Any wifi connection I have set in manually works every time. In these cases I have put in the code as I would on my Mac. Those that I have chosen from a list, even the ones that don't show the lock, sometimes disallow any actual use. I find this the most when I choose a coffee shop wifi, but you then have to sign in before it releases the ability to surf.

    I usually open Safari and update the page, which generally gets diverted to the sign in page in this situation. Not always this, but may help.
     
  9. mathewr thread starter macrumors 6502

    Joined:
    Sep 14, 2007
  10. Vedhead macrumors member

    Vedhead

    Joined:
    Jan 13, 2008
    #10
    I occasionally have wifi problems too...the checkmark is next to my wifi, then i exit out of settings and the Edge E pops back up...this is always fixed by doing 1 of 2 things: 1. turn wifi off. unplugging my modem and router and restart them (modem, then router, then turn iphone wifi back on) 2. power off the iphone for a few minutes then turn it back on.

    i had an issue where my iphone alarm would go off in the morning to wake me up, and if i didnt get to it quick enough to turn it off before the wifi tried to connect, the phone would freeze and the alarm would keep chiming until i did a hard reset. I have been turning the wifi off at night and i havent had that problem in a while...
     
  11. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #11
    I have AT&T DSL and WiFi...

    at the house and it requires a WEP Password initially, and once I enter the password, it seems to be set for life. :cool:
     
  12. rje macrumors regular

    Joined:
    Feb 12, 2008
    #12
    WiFi works perfectly for me, except at my office. There I get all bars showing on the indicator, but I can't connect to anything. The error message says it can't connect to the server. WiFi at the same location is excellent with a laptop, and it worked with previous WiFi phones I've owned. Any thoughts on this?
     
  13. JML42691 macrumors 68020

    JML42691

    Joined:
    Oct 24, 2007
    #13
    Are you sure that it is not the way that you have the connection set up at your router? You might have MAC Filtering, by then again, you wouldn't be able to connect to the signal at all.
     
  14. rje macrumors regular

    Joined:
    Feb 12, 2008
    #14
    All I know is that WiFi works everywhere except in that location, and every other WiFi device works in that location.
     
  15. Luap macrumors 65816

    Luap

    Joined:
    Jul 5, 2004
    #15
    I too have had this "Cant connect to the server" thing an awful lot too. And ive only had my iPhone a couple of weeks. It works perfectly on my home network, but now im getting the error on pretty much any other open network I find. Including "The Cloud" networks which are free access points in the UK for iPhone users. It worked once, and now it never seems to work at all.
     
  16. olbeune macrumors newbie

    Joined:
    Mar 4, 2008
    #16
    Hi, I have the same problem with my touch. The wifi works everyhwhere except at my college. it recognizes the wifi, but safari "can't connect to server". Other students with iphone or itouch have the same problem as me.
    It seems to be a dns problem as safari works only if i put the dns adress of the website. for instance, i tried entering the dns adress of google in safari, and it worked. I looked at a lot of iphone forums and didn't find any answer to my problem.
    Anyone has a solution ?
     
  17. SFC Archer macrumors 68000

    SFC Archer

    Joined:
    Nov 9, 2007
    Location:
    Troy, MT
    #17
    My first phone, purchased on iDay had the same symptons that all of you are reporting above along with a battery that would not hold a charge. I fought for two weeks to get that thing to lock on to my wifi and it just wouldn't do it.

    Called up applecare, opened a trouble ticket and sent the phone in for repair/replacement. During their analysis they determined that the phone was broke and replaced it. When I recieved the new phone it instantly connected to my wifi with no hassles or headaches and has been working perfectly since July 07

    Recommendation...its broke, get it replaced.
     
  18. HotblackDesiato macrumors member

    Joined:
    Feb 16, 2008
    Location:
    Scotland
    #18
    Sounds like a router admin problem.

    Ensure you router is not restricting access via MAC address (or add your iPhone's MAC address to the access list).

    Assign a static IP address to your iPhone.
     
  19. outkaste25 macrumors member

    Joined:
    Aug 31, 2007
    #19
    May seem stupid, but have u tried turning wifi off on the iphone and back on to see if it reconnects?
     
  20. FoxyApple macrumors newbie

    Joined:
    Feb 15, 2008
    Location:
    Harrisburg, PA
    #20
    amen brother i was on a ski trip last week and the following happened: i was in the denver aiport couldnt use the wireless. i stayed in a super 8 motel in dilon Colorado, couldnt use their wifi. i was in a keystone condo in Colorado, couldn't use their wifi. but when i am home it works fine on my wifi (and no i dont password my network)
     
  21. rjohnstone macrumors 68030

    rjohnstone

    Joined:
    Dec 28, 2007
    Location:
    PHX, AZ.
    #21
    Not true... even with MAC filtering, you would still "connect".
    It would be an unusable connection i.e., no IP assigned.
    The iPhone isn't smart enough to let the connection go even though it isn't valid.

    Most common issues are caused by the encryption protocol used.
    The iPhone supports WEP and WPA-PSK [TKIP].

    The iPhone does not support WPA2-PSK [AES] or RADIUS connections.
    So check your settings on the router first.

    Those of you unable to connect at work are most likely filtered out as an unauthorized device.
     

Share This Page