akacaj

macrumors regular
Original poster
Dec 21, 2008
227
0
NY
I have two access points, a D-Link Gamer Lounge and a Time Capsule both configured in 2.4 Ghz n/g compatible mode using the same SSID. My iPhone and iPad can roam between the two with no issues. They automatically choose the stronger signal as you approach the closer AP.
This also used to work fine in Snow Leopard. However Lion refuses to let go of the weak connection. Transmit rate drops down to 5Mbps as I walk away from the connected AP and standing right next to the other AP but Lion refuses to connect unless I turn WIFI off and back on again. In which case it picks the closer one. Same results on a Macbook Pro and a Macbook Air so it is not hardware specific.

Are you aware of any way change the threshold of when to look for a stronger signal?
 

akacaj

macrumors regular
Original poster
Dec 21, 2008
227
0
NY
Problem Solved!

Solved my problem. You have to ensure that both AP's are broadcasting the same exact security type. In my case one router I had set to WPA/WPA2 while the other was WPA2 only. While my other devices worked fine, Lion seems to be sensitive to this difference. Once I made that change everything worked fine.

You can see what your routers are broadcasting via this command:

cd /System/Library/PrivateFrameworks/Apple80211.framework/Resources
./airport -s
 
Comment

mrapplegate

macrumors 68030
Feb 26, 2011
2,818
8
Cincinnati, OH
Solved my problem. You have to ensure that both AP's are broadcasting the same exact security type. In my case one router I had set to WPA/WPA2 while the other was WPA2 only. While my other devices worked fine, Lion seems to be sensitive to this difference. Once I made that change everything worked fine.

You can see what your routers are broadcasting via this command:

cd /System/Library/PrivateFrameworks/Apple80211.framework/Resources
./airport -s

or hold down the option key when clicking the airport menu.
 
Comment

akacaj

macrumors regular
Original poster
Dec 21, 2008
227
0
NY
or hold down the option key when clicking the airport menu.

Thats one way but it doesn't give you the whole story and you can only see 1 AP at a time. It would also be misleading as it would always show you the currently used security method not all the available options. In which case my laptop would always use WPA2 to connect because the router in question supported both WPA and WPA2.

Command line shows all AP's and the exact string you need to be concerned with.

Sample output (security column) output:

AccesPoint1 WPA(PSK/TKIP/TKIP)
SomeOtherAccessPoint WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP)
JetAnotherAccessPoint WEP
AccessPoint2 WPA(PSK/TKIP,AES/TKIP) WPA2(PSK/TKIP,AES/TKIP)

It turns out that starting with 10.6.5 unless the two AP's had the same exact security string it would fail to switch over to the one with the stronger signal because it would assume that it is not on the same network.
 
Comment

mrapplegate

macrumors 68030
Feb 26, 2011
2,818
8
Cincinnati, OH
Thats one way but it doesn't give you the whole story and you can only see 1 AP at a time. It would also be misleading as it would always show you the currently used security method not all the available options. In which case my laptop would always use WPA2 to connect because the router in question supported both WPA and WPA2.

Command line shows all AP's and the exact string you need to be concerned with.

Sample output (security column) output:

AccesPoint1 WPA(PSK/TKIP/TKIP)
SomeOtherAccessPoint WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP)
JetAnotherAccessPoint WEP
AccessPoint2 WPA(PSK/TKIP,AES/TKIP) WPA2(PSK/TKIP,AES/TKIP)

It turns out that starting with 10.6.5 unless the two AP's had the same exact security string it would fail to switch over to the one with the stronger signal because it would assume that it is not on the same network.

Got it, I thought you were just looking to see if each access point was using WPA2 or just WPA for example.
 
Comment

spidey3

macrumors regular
Jul 1, 2010
195
0
Why do you want both AP's to have the same SSID?

Doesn't this just add complication, and obscure what is going on when you try to figure out which one you are connecting to?

Spidey!!!
 
Comment

akacaj

macrumors regular
Original poster
Dec 21, 2008
227
0
NY
Because if they had different SSD's you wouldn't be able to roam from one to the other seamlessly. You would go back to the original problem that I was having. Computer would think that it is a different network and it would hang on to its current weak connection as long as it can even if you are standing right next to the other AP with 100% signal.
 
Comment

msbdude

macrumors newbie
Aug 23, 2012
19
0
baja california norte
problem solved

Because if they had different SSD's you wouldn't be able to roam from one to the other seamlessly. You would go back to the original problem that I was having. Computer would think that it is a different network and it would hang on to its current weak connection as long as it can even if you are standing right next to the other AP with 100% signal.

this thread solved my similar problem. thanks to all :D
 
Comment

branqazwsx

macrumors newbie
Jun 11, 2009
3
0
Same Problem on my MacBook Pro OS 10.8

I continue to have a problem roaming between two routers setup the same way. I only have the problem on my MacBook Pro running 10.8, no problem on my iPad. I have the same WAP2 Personal security settings on both routers. My problem seems to be with the MacBook Pro are there any settings that I might be missing on it?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.