WIFI shows connected after sleep, but no internet connection

Hdub32

macrumors newbie
Original poster
Feb 19, 2015
25
0
I tried doing a search but could not find anything...

When I wake my macbook pro from sleep the wifi symbol is connected and not greyed out like it is on my iMac, and even though it is showing connected there is no internet connection.

I have to turn wifi off then on again. I don't have this issue with my iMac or any of my iOS devices on the same network.

I thought the issue was with quitting out of safari before putting machine to sleep, but problem still persists.

Any help would be appreciated...
 

alexwong27

macrumors newbie
Nov 19, 2014
1
0
I have this same exact issue. Not really sure what's causing it, but the only way I know to resolve the issue is doing exactly what you said. It gets annoying when it constantly shows up
 

ViciousShadow21

macrumors 68020
Mar 11, 2009
2,489
0
To your left or right
I have the same problem with my 5k iMac. I'm thinking the problem is with the keychain access. Turning on and off wifi doesn't work for me. I have to go into network preferences, then to diagnostics, and then I have to say allow access to keychain. What is really annoying is I click on the "always allow" option and I thought that would fix the problem but of course it doesn't. Everytime I wake the computer from sleep it says it's connected but cannot connect to the internet. Any help would be greatly appreciated.
 

xxddiaz003xx

macrumors newbie
Oct 12, 2010
2
0
I tried doing a search but could not find anything...

When I wake my macbook pro from sleep the wifi symbol is connected and not greyed out like it is on my iMac, and even though it is showing connected there is no internet connection.

I have to turn wifi off then on again. I don't have this issue with my iMac or any of my iOS devices on the same network.

I thought the issue was with quitting out of safari before putting machine to sleep, but problem still persists.

Any help would be appreciated...
Hey bud, idk if this helps because I am on a windows 10 hp spectre i7. I'm having the same issue that you are. Every single time i close my laptop then open it back up, my wifi will show connected but it will not browse (no internet connection). i just took my previous laptop back because of this issue and a couple more (sound,bluetooth). i opened up "device manager" and located my "network adapter" right clicked and selected "update driver". the update downloaded and installed, i rebooted, updates were applied, and then i tested the issue multiple times and have not had any issues. im not too familiar with macs, but i figured its worth a shot.

so my suggestion is attempt to update your network adapter driver.

just a little more info: both spectres i have are brand new from best buy. both had the same wifi issue, the update seemed to fix it. i made this account just to try and help lol. good luck!

excuse any typos, capitalization, etc. kinda in a hurry.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.