Wifi shuts off with sbsettings (iphone4)

Discussion in 'Jailbreaks and iOS Hacks' started by CliffLee, Aug 4, 2010.

  1. CliffLee macrumors newbie

    Joined:
    Apr 9, 2010
    #1
    I recently downloaded sbsettings with my iPhone 4 and the wifi keeps randomly turning off, any ideas why??
     
  2. BleB macrumors newbie

    Joined:
    Oct 31, 2010
    #2
    <Bump>

    Exactly the same happened to me. Anyone know why?

    Thanks
     
  3. AdamA9 macrumors 6502a

    Joined:
    Feb 2, 2010
  4. scottfenner macrumors newbie

    Joined:
    Aug 12, 2008
    #4
    I also get this problem on my iPhone 4. The toggle turns itself red and won't turn back to green. Even when I go into the wi-fi settings and turn it on, there is just the switch saying "on" and no network names underneath. A reboot is the only way to fix it.
     
  5. Absolem macrumors regular

    Joined:
    Jul 14, 2010
    #5
    should not happen, i don't have this problem. Try reinstalling and then rebooting your phone.

    If it still happens, see if there is another source to download it from.

    I've personally never had any issues with sbsettings.
     
  6. scottfenner macrumors newbie

    Joined:
    Aug 12, 2008
    #6
    Have tried reinstalling before but it happened again. I also recently restored my phone recently and was surprised to see that the problem still didn't go away.

    I've always downloaded it from the Big Boss source in Cydia.
     
  7. Wicked1 macrumors 68040

    Wicked1

    Joined:
    Apr 13, 2009
    Location:
    New Jersey
    #7
    Check your SB settings, you might have it set to Auto Off

    Swipt then Select more and go thru all your settings that way, I had SSH auto on when I did not want it that way, also I had a similar problem with BlueTooth until I figured out the settings was causing my issue.


    Good Luck
     
  8. scottfenner macrumors newbie

    Joined:
    Aug 12, 2008
    #8
    Thanks for the tip but I've been through everything on the 'More' settings bit and the only thing I can think that you mean is the 'Set Toggles' section. Wi-fi is simply set to 'on'. That only means that the toggle will appear when I activate SB settings though. In the same way, my SSH toggle is set to 'off' but I can still SSH into my phone.
     
  9. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #9
    Where is this auto-on toggle in SBSettings? I've looked through every menu and see nothing of the sort.
     
  10. goodkat macrumors newbie

    Joined:
    Dec 11, 2009
    #10
    have you try reset network settings?
    I have the same issues with WiFi and Bluetooth.
    I reset the network settings and connect to iTune, the WiFi became normal again.
    for Bluetooth, I use iBlueNova, it will turn off my WiFi all the time.
     
  11. scottfenner macrumors newbie

    Joined:
    Aug 12, 2008
    #11
    It's been a while since I reset network settings but I have tried it before. Have just reset them again though, thanks, will see how long it lasts!
     
  12. lurkingdoubt macrumors newbie

    Joined:
    Dec 2, 2010
    #12
    I've had this problem through the last two versions of SBSettings (ie 3.2.1 and 3.1.1-1) and two versions of iOS, 4.1 and 4.0.1.
    Has anyone found a solution to this because this happens so often i can't use sbsettings on my phone
     
  13. seanwebb68 macrumors 6502

    Joined:
    Jul 27, 2010
    #13
    can you post what cydia things you have installed as i had this problem and removed a few programs from cydia and it went away maybe i can work out what program it was from your list
     
  14. lurkingdoubt macrumors newbie

    Joined:
    Dec 2, 2010
    #14
    Sure. the cydia apps i have installed are:
    iFile, Terminal, Winterboard, Multi Cleaner, GPSPhone, Maddox Reader, Infinifolders, OpenSSH, PlayAwake, YourTube and some sources, repos and themes.
    When i use SBSettings i also have the springflash toggle

    Thanks for the help
     

Share This Page