Wifi suddenly not working with new networks?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Nytro, Dec 15, 2014.

  1. Nytro macrumors newbie

    Joined:
    Oct 23, 2010
    #1
    This is already my second iPhone 5, since the last one went into warranty because, ironically, of a wifi problem.
    The other day, I was just minding my own business when I decided to try to connect to the local wifi of the place I was at the time, and it wouldn't connect. It would find the network, I would put the given password in and it just stayed there. The keyboard would disappear, like it normally would, but instead of returning to the wifi menu in the Setting app, it just stays there saying "Connecting to "X"..." (X being the network's name) and nothing happens, unless I do either thing:
    -if I press the Home button, be taken to the main screen and then tap back to Settings, it brings me back to the wifi menu, still unconnected;
    -if I drag down Notification Center or bring up Control Center and bring them up/down again, a pop up shows up saying "Can't connect to the network".

    Apparently, this is to new networks, since that, when I got home, it automatically connected to my house's wifi. On the spot, I tried reseting everything from factory, and tried to connect to another wifi nearby, since I had a copy of my phone on iTunes, and it worked, it connected, but when I came back to the other wifi spot, it didn't but I scratched the option that it was a router problem, because now I'm at my other apartment in the capital, and tried to connect to wifi (since I reseted everything and had no password saved automatically) and the same thing happened, can't connect.

    Help me out here, I'm going insane!
     
  2. pmkoch macrumors regular

    Joined:
    Oct 18, 2009
    #2
    I had the same problem on iOS8.1. When I updated to iOS8.1.1 it fixed it.
     
  3. Nytro thread starter macrumors newbie

    Joined:
    Oct 23, 2010
    #3
    Really? 'Cause I'm still on 8.1. Maybe if I update it'll fix it, but I wanted to wait, because I've jailbreak and I wanna wait 'till this weekend so I can download the 8.1.2 jailbreak for Windows (I use Mac and I don't have a Win PC nearby).

    But is it normal for this to just randomly happen? Because until like 4 or 5 days ago, it was perfect...
     
  4. pmkoch macrumors regular

    Joined:
    Oct 18, 2009
    #4
    I haven't really read about anyone else having the issue but I had the exact same issue. I was able to connect just fine until one day when I tried. I updated to 8.1.1 and connected to the same network I was trying just fine. I haven't had any issues since.
     
  5. Nytro thread starter macrumors newbie

    Joined:
    Oct 23, 2010
    #5
    I really freaked out, because this is my second phone already, and here in my country, the warranty service sucks really bad, they take like 2 months to give you the phone back, I don't wanna wait all that time again.

    So you had the exact same issue? It would just stay there, connecting on the password screen? Really odd, isn't it?
    I guess I'll wait until friday, then. Maybe the problem will be solved by then. Thanks a lot, man. I'll quote you back here if I have any news by friday or saturday! :)
     

Share This Page