iPhone WiFi Sync on iOS 7 not working

rhaleuk

macrumors member
Original poster
May 23, 2007
59
0
Is anyone else not able to sync over WiFi on iOS 7? Tried lots of ideas to kick it into gear but no luck.

Any suggestions?
 

Vertigo50

macrumors 65816
Apr 11, 2007
1,197
131
Probably a bug. Same thing here.

I tried:

Restarting iTunes
Cycling Wifi on/off on my laptop
Airplane mode on/off on iPhone

It's just not showing up in iTunes.


Just to be sure, when the iPhone was plugged in by USB, did you make sure the option was checked in iTunes? It will be unchecked by default when you restore the phone with iOS 7 I think.

Again, it's probably a bug that will get fixed in the next release.
 

rhaleuk

macrumors member
Original poster
May 23, 2007
59
0
Yep. It's checked in iTunes. And syncs fine plugged in.

I'm used to needing to restart iTunes every so often to kick WiFi sync back into gear, but this is properly 100% not working right now.
 

Charlesblackwel

macrumors newbie
Dec 5, 2012
2
0
Wi-Fi Syncing Still Broken In iOS 7 Beta 2

iTunes 11 and iPhone 5 still won't sync over Wi-Fi for me with the second beta release. Anyone have any success?
 

Lads royals

macrumors newbie
Jul 2, 2013
1
0
Same problem with iPad 4

I hAve an iPad 4 and iTunes 11 and no wifi sync for me either:( hopefully they fix this with the 3rd beta coming out on the 8th
 

Martin-Alex

macrumors newbie
Jul 8, 2013
1
0
London
WiFi Sync on iOS 7 not working

Guys, I've been having the same problem since installed iOS7 beta 1 on iPhone 5. No Wifi sync at all. Today it has changed. Just installed Mobile Device Installer Package (MobileDevice.pkg) from here: http://bit.ly/1aiwZr1.
It just works :)
 

Gjwilly

macrumors 68030
May 1, 2011
2,872
513
SF Bay Area
For Windows users WiFi Sync has been disabled.
For Mac users install the Mobile Device Installer Package.
The release notes fully explain everything.
 

pero.s

macrumors newbie
Sep 20, 2013
1
0
Found a solution

The solution is to reset the setting on your iPhone or your iPad. I mean reset in the very meaning of the word.

I don't use Windows, so this is tested only with Mac OS (10.8.5).

1. Connect your mobile device to the usb-port of your Mac.
2. In iTunes switch to your device.
3. On the summary-page (first page) uncheck the option for wireless syncing ("Sync with this iPad/iPhone over Wi-Fi")
4. Press the button "Apply"
5. Press the button "Sync"
6. Check the option for wireless syncing again.
7. Press the button "Apply"
8. Press the button "Sync"

That's it. This worked for me.

As of now your iTunes-Wi-Fi-Sync is active again on your mobile device.
 

worldsdream

macrumors newbie
Feb 9, 2013
12
4
The solution is to reset the setting on your iPhone or your iPad. I mean reset in the very meaning of the word.

I don't use Windows, so this is tested only with Mac OS (10.8.5).

1. Connect your mobile device to the usb-port of your Mac.
2. In iTunes switch to your device.
3. On the summary-page (first page) uncheck the option for wireless syncing ("Sync with this iPad/iPhone over Wi-Fi")
4. Press the button "Apply"
5. Press the button "Sync"
6. Check the option for wireless syncing again.
7. Press the button "Apply"
8. Press the button "Sync"

That's it. This worked for me.

As of now your iTunes-Wi-Fi-Sync is active again on your mobile device.
ios 7, iphone 5, macbook pro retina.
tried everything to get my iphone showing in the sidebar. nothing helped till i read this post. thanks champ!
 

Armen

macrumors 604
Apr 30, 2013
7,375
2,207
Los Angeles
Is anyone else not able to sync over WiFi on iOS 7? Tried lots of ideas to kick it into gear but no luck.

Any suggestions?
Wifi sync is a pain in the ass. I don't use it anymore because sometimes it won't even detect the phone. It's faster for me to just plug it in.