Wifi sync when Mac is asleep

Discussion in 'iOS 6' started by jjk454ss, Nov 30, 2012.

  1. jjk454ss macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
    #1
    I just got a Mac Mini, if I want my ipad and iPhone to sync over wifi when charging, do I have to wake my Mac before I plug in the ipad/iPhone? With wake over LAN is there a way to make it sync even when the Mac Mini is asleep? What's the best way to make it sync automatically? I rarely use the Mac, but I'd like to know my ipad and iPhone are backing up to it regularly.

    Not really an iOS question, but with iTunes 11, can.i set it up to automatically download available app updates?
     
  2. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #2
    Your Mac needs to be awake, so your best bet is just not to let it sleep.
     
  3. brylliant macrumors regular

    brylliant

    Joined:
    Jul 18, 2012
    Location:
    United Kingdom
    #3
    In any case, your Mac needs to awake for it to be Wi-Fi syncing. iTunes also needs to be on, even if you have it minimised.

    As far as I know, you can't set up automatic downloads of apps in iTunes 11 or earlier.
     
  4. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #4
    In your Mac's system preferences, go to 'Energy Saver' and then 'Schedule.'

    Set your Mac to wake up at 3 AM every day and then to go to sleep at 3:45 AM. That should give your phone a chance to check in every night. Then, just make sure you always have iTunes running.

    Check and see if it's working, I don't know how often the phone checks, I'd assume 45 minutes is enough time.

    (Also make sure your Mac is not set to fall asleep in under 45 minutes so that it stays on that whole time. If you have it set for the monitor to go off sooner and for the hard drives to spin down by itself then it's not wasting much power to let it stay on for an hour.)
     
  5. jjk454ss thread starter macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
    #5
    Thanks for the help. I'll just leave it on for now, but I'll check into scheduling it to wake on its own and see if that works.
     

Share This Page