WiFi takes too long to connect after sleep

Discussion in 'OS X Mavericks (10.9)' started by na1577, Oct 23, 2013.

  1. na1577 macrumors 6502a

    Joined:
    Jan 20, 2008
    #1
    Is anybody else having this problem? In Mountain Lion, my Air would connect to my home network near instantly. Since installing Mavericks, whenever I wake up the computer it takes up to a minute before it even detects any networks.

    When first booting up the computer, it has no problems connecting. This only happens when it is woken from sleep.
     
  2. jsf8x macrumors 6502

    jsf8x

    Joined:
    Feb 28, 2010
    #2
    This has been happening to me as well, thought I might have been overthinking it since I hadn't read it elsewhere.

    I'm connecting to a university network if that matters in the slightest.
     
  3. aicul macrumors 6502a

    Joined:
    Jun 20, 2007
    Location:
    no cars, only boats
    #3
    Same here, I unfortunately also had this with ML as well
     
  4. MajkJaro macrumors member

    Joined:
    Apr 2, 2013
    #4
    I am a ML user also and I use 2 wifi routers at my home and my work. One works immediately after opening my rMBP13 and one needs 5 sec. I think it the router fault but it doesnt crash so it doesnt bother me much.
     
  5. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #5
    Have you tried deleting and readding the wifi information setup or creating a new location and adding the wifi router information there, these are usually the recommended procedures to fix these related error types.
     
  6. aicul macrumors 6502a

    Joined:
    Jun 20, 2007
    Location:
    no cars, only boats
    #6
    I'm not the thread starter so I do not want to hijack this. However, I did try that without improvement on the connection speed.
     
  7. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #7
    My MBP will either reconnect quickly but say I have no internet access or will just try to connect without success. I'm sure this has happened throughout the Mavericks DPs.
     
  8. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #8
    You could try to create static ips instead of handing out dhcp addresses and see of this helps.

    You could disable security and see if this helps as well. Then re-enable and use wpa2 if possible.
     
  9. na1577 thread starter macrumors 6502a

    Joined:
    Jan 20, 2008
    #9
    I did try deleting and re-adding, and I already use a static IP for stability issues. The problem isn't that it has trouble connecting to my network, but that it takes too long to find any networks. Once it detects all the nearby networks, it connects to my network very quickly.

    It's good to know I'm not the only one having this problem. Hopefully Apple will have a fix for this soon, internet issues are incredibly frustrating.
     
  10. goodgrief macrumors newbie

    Joined:
    Feb 10, 2014
    #10
    WiFi 802.11 band change may solve this

    I've had the same problem as many others on Mavericks - with Bluetooth enabled, my Macbook Air wifi would not reconnect after waking up from sleep.

    Today, I changed the 802.11 band on my wifi router from 2.4 GHz to 5 GHz, and the problem disappeared - my computer connects every time after waking up from sleep.

    One remaining problem - my old iPhone 4S does not support 5 GHz :-(
     
  11. IndyMichael macrumors newbie

    Joined:
    Feb 14, 2014
    #11
    Same here

    just joined this forum because of this issue. If anyone finds the fix, i really want to know.

    I tried deleting old wifi spots and just about everything else i can think of.

    Wasn't sure if it was because i migrated my old air book to my new macbook pro or not?

    From what i read, its a known Mavericks issue?

    Any help is appreciated!
     
  12. maxatwork macrumors newbie

    Joined:
    Mar 26, 2014
    #12
    Seems like Bluetooth somehow interfere with 2.4GHz wi-fi, so when Bluetooth turned on, I have this issue on all my three MBAs: mid2013 MBA 13" (10.9.2), mid2011 MBA 13" (10.9.2) and mid2012 MBA 11" (10.8.5).

    If I turn Bluetooth on, all of them will look for networks significantly longer, then with Bluetooth turned off (about 5-10 times longer). Turning Bluetooth off or switching router to 5GHz mode eliminates this problem.
     
  13. Kobayagi, Mar 26, 2014
    Last edited: Mar 26, 2014

    Kobayagi macrumors 6502a

    Kobayagi

    Joined:
    Dec 18, 2012
    #13
    I'm also having issues with this. My ethernet to usb connector doesn't work after sleep. And occasionally it just stops working while browsing. And same goes if I use wifi instead. Unplugging and plugging the ethernet to usb does fix it, but it's just annoying. I never had these problems with Mountain Lion.

    These OSX versions are getting worse and worse. Yes, they are adding more features, but they are followed by even more bugs and various unnecessary restrictions.
     
  14. IndyMichael macrumors newbie

    Joined:
    Feb 14, 2014
    #14
    I tried this out and can see what it does. It def has wifi wakeup quicker--when it wants to wake up that is!

    Unfortunately this didnt solve my issue. I intend to go to the genius bar one of these days...if they help with a solution i will post it. Thanks for the idea!
     
  15. knoxtown macrumors 6502

    Joined:
    Nov 19, 2007
    Location:
    Everywhere
    #15
    I just wanted to throw my hat in the ring. I'm having the same problem too. In addition, my bluetooth Magic Mouse disconnects frequently too.
     

Share This Page