WiFi turns on automatically?

Discussion in 'MacBook Pro' started by programmer<3, Aug 26, 2014.

  1. programmer<3 macrumors newbie

    Joined:
    Aug 22, 2014
    #1
    I recently got my macbook pro 15" retina mid-2014. I always put the WiFi to off before shutting down my mac. But, at times, the wifi automatically turns on when I switch on my computer. Is this expected behaviour? Does it happen to you too?

    Thank you.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Why do you turn Wi-Fi off? For that matter, why do you shut down your MBP, instead of using sleep mode? Your Mac looks for a Wi-Fi network in case you need internet access to restore your Mac on startup.
     
  3. programmer<3 thread starter macrumors newbie

    Joined:
    Aug 22, 2014
    #3
    So you mean to say that it is normal behaviour? but it doesnt happen always....
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    I just turned my Wi-Fi off and restarted. It booted up with it off. Have you checked your startup items?

    You didn't answer the questions I asked. Why are you turning Wi-Fi off, and why are you shutting down, instead of sleeping your MBP?
     
  5. programmer<3 thread starter macrumors newbie

    Joined:
    Aug 22, 2014
    #5
    This is my first experience with macs. I have a habit of shutting down my computer, courtesy windows. Is sleep mode better? I switch off the wifi without any apparent reason. I normally use an internet dongle, so wifi is off.

    Edit: I checked my startup items. I think the behaviour is because of iTunes helper.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    With the MBP, you can leave Wi-Fi turned on all the time. There's no need to turn it off. Also, you can simply close the lid to put your Mac in sleep mode. Many Mac users run months at a time without shutting down or restarting, with no degradation in performance. OS X has background maintenance scripts that run on a daily, weekly and monthly basis. They are scheduled for the early morning hours, like 3AM and other times. If your Mac is shut down at the scheduled times, the scripts will not run. If your Mac is asleep at the scheduled times, the scripts will run in the background when your Mac is awakened. For that reason, it's better to use sleep instead of shutting down.

    This may be useful, if you haven't seen them already:

    http://www.apple.com/support/macbasics/
    http://www.apple.com/support/
     
  7. snowyjoey macrumors newbie

    Joined:
    Jan 15, 2012
    #7
    I have this problem constantly. I am extremely sick of it and suspicious of it too. For several YEARS I have had WiFi turned OFF. It never ever once turned "itself" back on. Being the admin of this machine, I assumed I am in control of settings like this. I read the above thread, and I am not looking for someone to sell me the benefits of WiFi or tell me what to do with my machine. If turning WiFi OFF was not supposed to be user interchangeable, why the hell would the computer have the option to do so?
    So.... Why is it that my WiFi turns itself on all by itself at random? Anyone know? I want it to stop. Apple don't seem to give a damn on their forums, which is no surprise given the past few years of decline in service there, so hoping someone here might have some ideas as to what process is causing it and how to resolve to allow me to use my computer with WiFi off like I have for so long. Thanks
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Did you check your startup items, as suggested to the other poster?
     
  9. snowyjoey macrumors newbie

    Joined:
    Jan 15, 2012
    #9
    Just for the benefit of others finding this thread, this continues to happen and has happened for years, however it ONLY happens when I launch PokerStars poker app on my iMac. I open the app, get the login box, and the second i hit "login", my WiFi turns on. I then have to manually turn it off, which can cause problems with other programs I am running as they temporarily lose connection. I have told PokerStars about it several times but they stick firmly to the "it's OSX causing this" line, which is complete rubbish. I can run my machine for weeks without the wifi coming on, but the second I log in to Pokerstars, on comes the wifi like clockwork.
     
  10. samsom macrumors newbie

    samsom

    Joined:
    Feb 2, 2018

Share This Page