Wifi wont reconnect

Discussion in 'Mac OS X Lion (10.7)' started by godcandy, Mar 12, 2012.

  1. godcandy macrumors member

    Joined:
    Mar 11, 2012
    Location:
    Texas
    #1
    So I have noticed sense I upgraded my MBP to 10.7 when I simply close the lid on it and then try to re-open it it will not connect to the wireless network again. The only work around I have found is to go in and disable wifi and re-enable it. Not sure what the deal is there. Anyone having similar issues or have any idea how I might fix it.
     
  2. thegreatdivorce macrumors regular

    Joined:
    Sep 23, 2010
    Location:
    Upper Left USA
    #2
    My MBA does that as well. Pretty obnoxious. Every time it sleeps, and is woken, it loses the connection. I don't have to turn the antenna on/off, but I do have to go click on the network again.

    What router are you using?
     
  3. Bigyella macrumors member

    Joined:
    Jul 10, 2009
    Location:
    Texas
    #3
    I have the same problem. I have to restart mine to work again. Turning the wifi off and on, does nothing. Sometimes it will be fine for a day or 2, then I will have problems with it multiple times a day. Its connected to a newer time capsule. No problems with any of my other devices connecting.
     
  4. oliviervdv macrumors newbie

    Joined:
    Feb 13, 2012
    #4
    Same here on iMac 21.5.

    I applied the recently released patch at least twice.
    It does work better than before though, but sometimes, it doesn't.

    I have to disconnected/reconnect for my network connection to work.

    Very annoying.
     
  5. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #5
    if you're on a 5g network, try changing it to 2.4g; worked for me.
    was having this problem constantly on my new mbp (my GF, on a late-2008 mbp, same OS, does NOT have the issue)...
     
  6. godcandy thread starter macrumors member

    Joined:
    Mar 11, 2012
    Location:
    Texas
    #6
    I will take a look... I think the one here at work has both 2.4 and 5... Not sure about mine at home. :/
     
  7. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #7
    i just redid my setup. replaced the airport express with a linksys dual-band router, and all is well (my GF is on the 5g connect, me and my iPhone use the 2.4)... everything works great.
     
  8. UTMAC macrumors newbie

    Joined:
    Mar 28, 2012
    #8
    I have noticed on my iMac 21.5in that when I wake it up, sometimes it can take a minute or two before the internet will pick back up, but it reconnects itself. Are you all saying that it wont come back at all?
     

Share This Page