iPhone Wifi won't turn on after iOS 6 update

Discussion in 'iOS 6' started by giper54, Sep 20, 2012.

  1. giper54 macrumors newbie

    Apr 30, 2012
    I have an iPhone 4S on AT&T. I updated to iOS 6 last night and after the update I can't get my wifi to turn on. When I go to wifi in settings it is greyed out. I know there is a wifi bug is this it. If not has anyone else experienced it and fixed it so wifi. Can turn on again
  2. Deanjmu macrumors newbie

    Sep 20, 2012
    I've been having the same exact problem and have been unable to find a way to fix it even after doing a network reset and a full system reset. Seems to be a bug with the new iOS, hopefully there will be a fix soon.
  3. downingp macrumors 6502a

    Jun 26, 2006
    Same problem here. There is a discussion all over the apple forums with no real fix. Some are even going as far as returning their phones back to apple.
  4. shanezam203 macrumors member

    Nov 14, 2011
    Same issue here on my iPhone 4s. Tried restoring in DFU mode and no dice, still not able to turn Wireless back ON in settings. I also tried resetting carrier network settings but that didn't help, any clue what else I can do?

    I restored the iPhone 4s to factory settings and still no wireless, it is greyed out and won't let me turn on.

  5. tmagman macrumors 6502

    Nov 7, 2010
    Calgary AB
    my mom just got an iPhone 5 about 3 months ago and this issue showed up last week. She took it into the apple store and they tried a full clean install but with no luck, they replaced it no questions asked. Apparently they've been seeing a number of these.

Share This Page