Wifi Wpa2 Enterprise for Watch OS 5

Discussion in 'Apple Watch' started by liteshow, Sep 18, 2018.

  1. liteshow, Sep 18, 2018
    Last edited: Sep 19, 2018

    liteshow macrumors regular

    Joined:
    Sep 20, 2012
    #1
    **** UPDATE****
    I was able to successfully join a wpa2 enterprise wifi while connected to my phone. I then turned off bluetooth on my phone and the watch connected automatically to the wifi. However, I tried it again later and now it won't connect anymore. I even went to settings -> wifi and made sure it was seeing the wpa2 enterprise wifi, but no go. No issues with non-enterprise wifi.

    I then restarted my watch and was able to connect to the enterprise network again. Sounds like we have a bug here.
    **** UPDATE****



    Has anyone successfully joined a Wpa2 Enterprise Wifi network? This issue is only with Wpa2 Enterprise that requires a login and password. I have no issues with standard wpa2 wifi that uses a passphrase.

    My observations: I am not able to connect. I tried both ways
    (1) Connect using my iphone first, but the credentials do not get passed on to the watch.
    (2) Use the watch to directly connect to the wifi, but it keeps saying I have the wrong password.

    The only possible cause I can think of is that when I join the particular Wpa2 Enterprise wifi using my phone or a laptop, it will prompt me to trust it's certificate. Maybe the watch has no way to trust the certificate or I need to import it in somehow?
     
  2. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #2
    I tried it at work and it did connect. I was prompted to accept the certificate on the watch. I did find it very frustrating to enter my wifi password accurately on the watch and I didn't get it right the first time.
    The second day I came to work, the watch reported that my password was incorrect and I have not tried connecting again.
     
  3. liteshow thread starter macrumors regular

    Joined:
    Sep 20, 2012
    #3
    I tried again and this time I made sure I was still connected to the phone via bluetooth. I was prompted with a certificate this time. I trusted it and was able to connect. Turned off bluetooth on the phone and the watch automatically connected to the wpa2 enterprise wifi.

    So what this means is if I don't have my phone with me (say I am out for a run without the phone), I would not be able to connect to a NEW wpa2 enterprise wifi. However, previously connected wpa2 Enterprise wifi will work.
     
  4. Steve28 macrumors regular

    Joined:
    Jun 14, 2011
    #4
    We have a hidden SSID WPA2 Enterprise network at work that we're supposed to use for "personal" devices. Is there a way to enter the SSID on the watch?

    Edit: My phone is work phone, but the watch is personal
     
  5. liteshow, Sep 19, 2018
    Last edited: Sep 19, 2018

    liteshow thread starter macrumors regular

    Joined:
    Sep 20, 2012
    #5
    I was able to successfully join a wpa2 enterprise wifi while connected to my phone. I then turned off bluetooth on my phone and the watch connected automatically to the wifi. However, I tried it again later and now it won't connect anymore. I even went to settings -> wifi and made sure it was seeing the wpa2 enterprise wifi, but no go. No issues with non-enterprise wifi.

    I then restarted my watch and was able to connect to the enterprise network again. Sounds like we have a bug here.

    --- Post Merged, Sep 19, 2018 ---
    There is no option to join "Hidden" or "Other" network. The iphone will pass on the connection info only for non-enterprise wifi's. Enterprise networks connections are not passed on to the watch.
     
  6. Steve28 macrumors regular

    Joined:
    Jun 14, 2011
    #6
    Doh! You're correct, of course. We have a hidden network for our personal devices at work it's WPA2 - not enterprise. We're not supposed to register our work phones on it, but I think that's the only way to get the info to the watch for hidden SSIDs, correct?
     
  7. Chewie16 macrumors newbie

    Joined:
    Sep 22, 2018
    #7
    Weird thing for me, i had watchOS5 on my series 2 and I was able to accept the security certificate and log in no problems. On my Series 4, after putting in user/pass, it just spins, trying to connect. I never get to accept a certificate.
     
  8. ginodesilva macrumors newbie

    Joined:
    Sep 25, 2018
    #8
    Only subscribed to (maybe) help others by explaining what worked for: I installed the certificate again on my iphone. It created a security profile and my iPhone asked me if I wanted to install it on my iPhone (and thus, replacing the one already there) or on my watch. I installed it on my watch and tried connecting to the network. After entering the name and password, it connected!
     
  9. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #9
    This configuration profile isn't a standard feature of WPA2 enterprise networks; it's something your particular network is configured to do.
     
  10. 22607277 macrumors newbie

    22607277

    Joined:
    Sep 30, 2018
    #10

    I have exactly the same issue. Started a discussion thread on apple support about it. https://discussions.apple.com/thread/8556259

    Sadly Watch OS 5.0.1 didn't fix it!
     
  11. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #11
    Bit late to the party with this, but in case anyone is still trying to figure this out I have a solution (well, one that worked for me). As per this link, if you have a cellular watch you need to turn off mobile data (as well as either putting your phone into airplane mode or being out of BT range of it) when you first connect to the 802.1X network. If mobile data is on, the watch won't ask you to accept the RADIUS certificate and will just time out trying to connect: if it's off, the watch offers the certificate for approval and connects fine. As per the above link, the procedure is:

    1. Put your iPhone into Airplane mode so the Watch can’t talk to it.
    2. Turn off Mobile Data on the Watch (if it has it).
    3. Touch Settings on the Watch, then Wifi. Choose the network you want. Enter your credentials. Tap connect. Trust the offered certificate.

    I suspect this is a watchOS bug (I can't see any logical reason for this behaviour) and have reported it to Apple, but the above worked for me in the meantime.
     
  12. liteshow thread starter macrumors regular

    Joined:
    Sep 20, 2012
    #12
    Unfortunately, your procedure does not work for me. Maybe because my watch is not cellular. There is no work around for me. Here is what I have to do every single time if I want to connect to the WPA2 Enterprise wifi:

    1. Settings -> Wifi. Pick the wifi SSID and choose "Forget this network"
    2. Power-off watch
    3. Power-on watch
    4. Select wifi SSID and re-enter credentials.

    Yes, it is such a hassle. Takes me like 5 - 10 mins to connect each time. Not mentioning it gets tricky the need to enter both the username and password every single time using the scribble function on the watch.

    I have already reported this bug to Apple but I bet it is on their lowest priority.

     
  13. bag99001 macrumors member

    Joined:
    Jun 11, 2015
    #13

    I just experienced this issue at my new job and your solution solved it for me! My IT Department said it wouldn't work but I knew there was an answer...Thank you so much!
     

Share This Page

12 September 18, 2018