Will a factory reset help here? (New battery 'X' after water spill)

Discussion in 'MacBook Air' started by booyahbooyah, Dec 4, 2015.

  1. booyahbooyah, Dec 4, 2015
    Last edited: Dec 4, 2015

    booyahbooyah macrumors regular

    Joined:
    Sep 11, 2011
    #1
    Macbook Air mid-2011 11" with El Capitan.

    Short story:
    1) Water spill on keyboard (a lot of water). Dried out laptop, it was still working fine. But the battery died.
    2) Have experience replacing battery. So bought new battery off Amazon. Get 'X' on new battery, and "No battery available." (Always green light on the MagSafe dongle, never the amber light.)
    3) Tried all the usual SMC, PRAM and 'hold Power button down for 10 seconds' tricks. Tried all possible combinations of doing these while Macbook was powered on, or powered off (with and without being plugged-in), and also with battery connected and disconnected and plugging in battery before and after power cable.
    4) Also tried the slight bending of the battery connectors (to improve contact pressure).
    5) Also re-installed OS X.
    6) The good news is: The hardware does detect the battery (even though the software doesn't). How do I know this? When I unplug the power cable, the fan keeps going. And then when I unplug the battery, the fan stops.


    Currently, I'm on iFixit figuring out how to take the Powerboard IO out, so I can scrub all contacts with alcohol using a toothbrush, in case there's corrosion.

    My question to you folks is: do you think a factory reset would help here?
     
  2. burne macrumors 6502

    burne

    Joined:
    Jul 4, 2007
    Location:
    Haarlem, the Netherlands
    #2
    What magic key combo would that be? You tried all I know already.

    I would contact the seller and complain about the battery not getting recognised. If he can't resolve the issue or tell you how to resolve it, return it.
     
  3. booyahbooyah thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #3
     

Share This Page