Will compiling with SDK4 to get the app switching still run on OS3?

Discussion in 'iOS Programming' started by danimal99, Jun 21, 2010.

  1. danimal99 macrumors regular

    Joined:
    Jul 21, 2008
    #1
    Since simply linking against SDK4 will give you the app switching code, does anyone know if the app will still run on OS3 if you don't change anything else?

    Thanks, Dan
     
  2. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A293 Safari/6531.22.7)

    Depends what your project's minimum OS deployment target is set to.
     
  3. Luke Redpath macrumors 6502a

    Joined:
    Nov 9, 2007
    Location:
    Colchester, UK
    #3
    Yes, just set your Base SDK to 4.0 (rule of thumb: always try and build using the latest SDK for the platform) and the deployment target to the minimum supported version.
     

Share This Page