Will iOS 7.1 update ACTUALLY fix calendar bugs?

Discussion in 'iOS 7' started by asggold, Jan 28, 2014.

  1. asggold macrumors member

    asggold

    Joined:
    Sep 21, 2012
    #1
    I would like to ask this question to anyone who has developer/testing access of the 7.1 beta releases:

    For the past year I have contacted apple support, looked over the web, forums, etc... to try and solve this issue around calendar notifications. Here is the situation:

    My wife and I each share our iCloud calendar with each other. I do NOT have the "show shared calendar alerts" checkbox checked (although I have verified it does not work as intended anyway). Every time she sends me an invite from her iCloud calendar to mine it comes in but NOT allowing me to accept as an invite, just to click "OK" (This is on my iPhone). If I log into iCloud on the computer it does allow me to accept as invite but usually crashes iCloud no matter if I accept or decline. If I go to back to my phone at the location in my calendar and look at the time where the invite was sent for, that is the only way I can actually accept, decline, etc...

    In addition, even though I do not have her calendar showing, it still shows me the notifications for EVERY one of her appts.

    I believe the bugs have something to do with the iCloud calendar and sharing specifically because everything works fine when I receive an invite from someone not using an iCloud calendar.

    Is there any way to actually turn off the notifications for shared calendars?
     
  2. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
    #2
    I really don't know much about calendar sharing etc., just trying to wrap my head around this. If you have a shared calendar, why are you sending invites to each other? Just add it to the calendar and it will appear on the others' device.
     
  3. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #3
    This is what I do. My GF just adds it directly to my calendar and I get the notification.
     
  4. asggold thread starter macrumors member

    asggold

    Joined:
    Sep 21, 2012
    #4
    We are not using just one shared calendar. Each of us have our own calendar but share the calendar just in case there is a need to see where someone might be in an emergency. Any invite both of us need to attend would be on both of our calendars. I do not want to see notifications for the shared calendar, just my calendars. I do not even have her shared calendar visible when looking at my iOS calendars.
     
  5. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
    #5
    Gotcha. Unfortunately I don't think there are separate notification settings per calendar, even on 7.1 betas, which I think is what you're after. I agree this would be very useful. Mail manages to have separate notification settings per account, why not Calendar?

    The best workaround I can think of is you both have your own private calendars, and either duplicate everything on one shared calendar or only add the things you really need on this shared one. Then, on the shared one, set the Event Alert to None. Not great, I know. Having said that, I'm merely assuming that 'Event Alert' is a setting shared between devices sharing the calendar. Perhaps it only pertains to the device? In which case, you might be able to locally set Event Alert to None on your wife's shared calendar on your device, without it affecting her device's alert? Something to try out, anyway.

    Can't comment on all the crashes you've been having- sounds awful.
     
  6. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #6
    If you don't want to see alerts for the shared calendar, disable the "Shared Calendar Alert" option in settings? I know you posted before that it does not work, but I have tested it and it does for me... but I am on iOS 7.1 beta 4 but I know that I used this before and it worked as described.
     
  7. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
    #7
    Pretty sure this setting only controls whether you get an alert when the shared calendar is modified, not when an event on that calendar occurs.
     
  8. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #8
    create a 3rd calendar that is only used for shared events instead?
     
  9. oneMadRssn macrumors 68040

    oneMadRssn

    Joined:
    Sep 8, 2011
    Location:
    Boston, MA
    #9
    I am not using iOS7.1 beta, so this isn't a direct answer to your question; more of a pile-on complaint.

    This seems to be more of an iCloud issue rather than an iOS issue. The exact same annoyances have led me to keep using Google Calendar rather an iCloud; and it works just fine and as expected, even on the iPhone.
     
  10. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #10
    Oh I see, yeah my misunderstanding.
     
  11. spooky2k macrumors 6502a

    #11
    It works a-ok for me and my girlfriend, so can't be a general bug.
     
  12. mattopotamus macrumors G4

    mattopotamus

    Joined:
    Jun 12, 2012
    #12
    Just adding on. I cannot receive calendar invites using an icloud email address. It is insanely annoying =/
     
  13. ctone macrumors member

    Joined:
    Nov 28, 2006
    #13
    There may be some confusion as to what a "Shared Calendar" is. In Apple terms, a "Shared Calendar" would not be calendars that are on the same Apple ID / iCloud account. They are calendars that you share by inviting or approving invites, etc. to others not sharing an iCloud account.

    A "Shared Calendar" is not where you can set up separate calendars on one iCloud account and sync across devices, with different calendars for different people (or different categories) on the same iCloud account. That is why the "Turn off Shared Calendar Alerts" does not work for calendars that are on the same iCloud account - they aren't "Shared Calendars".

    HOWEVER, it is possible to disable the notification alerts from calendars that are on the same iCloud account but are turned off on an OSX Mac. Right click on the name of the calendar that is turned off in OSX Calendar, select "Get Info", then check "Ignore Alerts". There just isn't a way to do this on an iOS device, so the issue is not with iCloud, it is simply a feature that is not available in iOS, unfortunately.
     

Share This Page