Will my iMac be compatible with OSX Mavericks?

Discussion in 'iMac' started by Miqs, Apr 22, 2015.

  1. Miqs macrumors member

    Miqs

    Joined:
    Mar 22, 2013
    Location:
    Bedfordshire, UK
    #1
    My Mac is late 2006, 2.16 ghz Intel Core 2 Duo, ATI Radeon graphics 128mb, 2.5gb ram, now running Lion 10.7.5. I read that the earliest iMacs suitable are mid 2007 but don't know if mine is the same slightly earlier version. I don't want to download a new OS if it's going to cause problems.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
  3. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #3
    If your iMac is white plastic, Lion is as far as you can go. If Aluminum, then good through the latest.
     
  4. Miqs thread starter macrumors member

    Miqs

    Joined:
    Mar 22, 2013
    Location:
    Bedfordshire, UK

Share This Page