Will Snow Leopard work with MySQL, Tomcat etc?

Discussion in 'Web Design and Development' started by raymondu999, Aug 28, 2009.

  1. raymondu999 macrumors 65816

    Joined:
    Feb 11, 2008
    #1
    Hey all. I'm a student in Uni doing INformation Systems. I'm wondering if things like Apache, Tomcat, and MySQL will work immediately flawlessly on Snow Leopard. I need these for project work so if they might not work on SL I might have to delay my upgrade plans:rolleyes:
     
  2. iShater macrumors 604

    iShater

    Joined:
    Aug 13, 2002
    Location:
    Chicagoland
  3. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
  4. xper macrumors 6502

    xper

    Joined:
    Dec 15, 2005
    Location:
    Sweden - Halmstad
    #4
    MySQL works with MAMP so it should work standalone to!
     
  5. bootedbear macrumors 6502

    bootedbear

    Joined:
    Sep 13, 2004
    Location:
    Austin, TX
    #5
    I've been running Tomcat since 10.0 and PostgreSQL since 10.4, and an upgrade has never cause any types of problems. I can't see SL being any different.
     
  6. brasscat macrumors 6502

    brasscat

    Joined:
    Jun 9, 2007
    Location:
    Dallas, Texas
    #6
    Last night I installed MySQL 64-bit onto SL and it works without a problem. If you use the service run/stopper in the preference pane, that works as well, but only in 32 bit mode.
     
  7. dbell macrumors member

    Joined:
    Jul 11, 2007
  8. tercerojista macrumors newbie

    Joined:
    Aug 29, 2009
    #8
    I was running MySQL on Leopard. Last night I installed Snow Leopard. I found that I could no longer get MySQL to run.

    I use the 'mysql.server start' command in terminal. The mysql.server executable is still on my computer. It's in exactly the same place:

    usr/local/mysql-5.0.51b-osx10.5-/support-files

    If I go there in terminal, and try the mysql.server start command, I get the message:

    mysql.server: command not found

    (yes, I'm running as SU)

    Not sure what's gone wrong here...

    I'm not greatly surprised that something went wrong here. When I Google for information about MySQL on OS X, I find SO MANY different ways of installing and starting the software, that it's all really rather confusing...
     
  9. raymondu999 thread starter macrumors 65816

    Joined:
    Feb 11, 2008
    #9
    so can I make the assumption that installing MySQL after an SL install works, but not having it run from a previous installation running on Leopard?

    How about Apache and Tomcat?
     
  10. Joined:
    Jun 30, 2009
    #10
    I'm not certain about Tomcat, but Apache should work as well, the version included with MAMP works.
     
  11. erichepler macrumors newbie

    Joined:
    Aug 28, 2009
    #11
    After Upgrade, MySQL stopped, now I fixed

    Was running php5 + MySQL.

    When i went to http://localhost i got "It Works!" instead of my application that i've been developing locally. I think thats an apache2 index error, i may just need to add index.php back to the index directives.

    When I loaded http://localhost/index.php explicity... php code executed but I could not connect to MySQL. I went to system preferences to the MySQL Admin icon, and it first said it needs to restart System Preferences in order to load MySQL Admin pane... ok... Did that, and there was an error saying could not find "/usr/local/mysql/bin/mysqld_safe". I went to the Terminal and saw that I didnt have a /usr/local/mysql but instead a /usr/local/mysql-5.1.30-osx10.5-x86 so I created a symbolic link "ln -s /usr/local/mysql-5.1.30-osx10.5-x86 /usr/local/mysql" and restarted mac and it works now. Everything seems kosher in my system preferences/mysql pane now too.

    Hope this helps some of you, perhaps I could have reinstalled MySQL to fix too.
     
  12. budhadha macrumors newbie

    Joined:
    Apr 17, 2009
    Location:
    Not far away
    #12
    I had the same problem here, you just have to go into /usr/local and make a soft link to your mysql directory version and name this link mysql. It solved the problem for me.
     
  13. elppa macrumors 68040

    elppa

    Joined:
    Nov 26, 2003
    #13
    Ditto.

    [1] Make a alias (soft link) called “mysql” in /usr/local/ that points to your mysql installation (it will likely be in /usr/local/ and called something like “mysql-5.0.77-osx10.5-x86”). In Terminal:
    Code:
    cd /usr/local/
    Code:
    ln -s /usr/local/mysql-5.0.77-osx10.5-x86/ mysql
    [2] Use the preference panel to start mysql.

    -or-
    If you have a Time Machine backup prior to upgrading:
    [1] Navigate to /usr/local/
    [2] Choose “Enter Time Machine” from the Time Machine icon in the menu bar.
    [3] Restore the mysql alias from the last backup you took prior to upgrading to Snow Leopard.
    [4] Use the preference panel to start mysql.

    It appears that when Snow Leopard upgrades from Leopard it removes this alias.
     
  14. tercerojista macrumors newbie

    Joined:
    Aug 29, 2009
    #14

    Thank you very much indeed! I was hoping for a simple solution :)
     
  15. superfunkomatic macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    calgary, ab canada
    #15
    i had an existing mysql build running. will this work and allow the old data to work?
    also do i need to install the 32 or 64 bit version of mysql for x86?
    i've restored to 10.5.x to keep my webserver working, but this would be great if it's a simple process of:

    1) install 64 bit mysql
    2) install startup item for mysql
    3) create soft link to new mysql directory
    4) and have all data work with existing web-based apps.

    any help would be appreciated.

     
  16. elppa macrumors 68040

    elppa

    Joined:
    Nov 26, 2003
    #16
    Yes, this is exactly the same situation I was in and after placing the link and restarting all my databases and tables were in place.

    You can use either, at present I am using 32 bit version of 5.0.77.

    I only needed to follow steps 3 and 4 after doing upgrade install.
     
  17. superfunkomatic macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    calgary, ab canada
    #17
    I didn't get a message to do an 'upgrade install.' i was running 5.1.30 32 bit version. would that make any difference?

     
  18. elppa macrumors 68040

    elppa

    Joined:
    Nov 26, 2003
    #18
    I think we may have our wires crossed… are you talking about upgrading mysql or Snow Leopard?

    Because I was talking about upgrading Snow Leopard. What I was saying is providing you add back the “mysql” alias in /usr/local/, everything should work after upgrading from Leo > Snow Leo.
     
  19. superfunkomatic macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    calgary, ab canada
    #19
    i updated to snow leopard and installed 5.1.37 - mysql didn't work. even with a fresh install mysql didn't work. that's why i thought that just adding a soft link seemed far to easy.
    i'll have to give it a try now that i've reverted/restored back to 10.5.8 and 5.1.30.

     
  20. elppa macrumors 68040

    elppa

    Joined:
    Nov 26, 2003
    #20
    This resolved the issue for me though - so it does work in some cases.

    When you say “didn't work”, what part didn't work – the preference panel?
     
  21. dccdk macrumors newbie

    Joined:
    Sep 12, 2009
    #21
    I attempted to create this soft link but received a permission denied message.

    Is there a way that I can work around this?
     
  22. GroovyLinuxGuy macrumors regular

    GroovyLinuxGuy

    Joined:
    Apr 2, 2006
    Location:
    Canada
    #22
    Use sudo before the command, then enter your password when prompted.
     
  23. DanRomanchik macrumors newbie

    Joined:
    Sep 29, 2009
    #23
    Thanks!

    Just wanted to thank all those who responded.

    I upgraded to Snow Leopard a couple of days ago, but only this morning needed to access some of the databases on my local machine. I thought I was hosed when I couldn't connect to the server. Adding that link did the trick, though!

    Dan
     
  24. trintha macrumors newbie

    Joined:
    Oct 2, 2009
    #24
  25. Kaenath macrumors newbie

    Joined:
    Oct 7, 2009
    #25
    10.4->10.6 upgrade

    I've upgraded my machine from 10.4 to 10.6.

    I see mysqld running in activity monitor, but when i try any mysql commands in terminal, they all fall.

    ProductionG5:local kaenath$ mysql
    -bash: mysql: command not found


    when checking my mysql folder, i'm seeing this version:

    mysql-5.0.45-osx10.4-i686

    Should I be upgrading this to a newer version? why didn't OSX upgrade it when I upgraded to SL?

    If upgrading, where should I get the newest version from (and instructions would be helpful). Do I need to uninstall my current version?

    Any current sql data is not needed.
     

Share This Page