Will Stronghold 1 for mac work on snow leopard?

Discussion in 'Mac and PC Games' started by j.burris, May 10, 2011.

  1. j.burris macrumors member

    Joined:
    Apr 21, 2010
  2. Killery96 macrumors 6502

    Joined:
    Mar 20, 2011
    #2
    Yes I believe it will, so long as it is universal binary.
     
  3. j.burris thread starter macrumors member

    Joined:
    Apr 21, 2010
    #3
    What's that mean?
    The game is for mac but from 2002.
     
  4. Killery96 macrumors 6502

    Joined:
    Mar 20, 2011
    #4
    If the game was made in 2002 it was likely targeting users of not Intel-based macs. This means that, if you are using a modern macintosh computer with an Intel Pentium, C2D, i3, i5, or i7 processor, the tech is 'too advanced' to play the game. However, as even 2001 games like Halo have universal binary counterparts, I believe that a 2002 game can be played on an Intel/OSX based mac.
     
  5. seb-opp macrumors 6502

    Joined:
    Nov 16, 2008
    Location:
    London/Norwich
    #5
    google 'universal binary'

    Since the game is older than all intel macs, it was originally designed to only run on PowerPC macs. There is a possibility that there could be a patch for the game to make it universal binary, allowing it to run on intel macs as well as PowerPC. I believe the game was ported to the mac by a company called Macsoft, so to find out if a patch exists, I'd start by looking on their site.

    There is a possibility there is no patch for it, in which case you need to use a program called 'Rosetta'. This used to be installed by default on all macs until 10.6, but I think it's still available on the Mac install DVD.
     
  6. j.burris thread starter macrumors member

    Joined:
    Apr 21, 2010
    #6
    There aren't any universal binary patches for it.
    I don't want to install windows or bootcamp either.

    If anyone knows of any games similar that would work please let me know.
    I like the ones where you build the city and train troops and stuff.
     
  7. Eric5h5 macrumors 68020

    Joined:
    Dec 9, 2004
    #7
    Stronghold works fine in Snow Leopard. You don't need a universal binary patch or anything.

    --Eric
     
  8. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    If it's not a UA then you'll need Rosetta but the system will prompt you to install it if you don't already have it. Easy :)
     
  9. j.burris thread starter macrumors member

    Joined:
    Apr 21, 2010
    #9
    I have a 2010 mbp 15 2.53ghz i5 with osx 10.6.7
     
  10. Eric5h5 macrumors 68020

    Joined:
    Dec 9, 2004
    #10
    As I said, it works fine. Don't worry about it. (As long as you don't upgrade to Lion anyway....)

    --Eric
     
  11. cpf100 macrumors newbie

    Joined:
    May 24, 2011
    #11
    I got Stronghold to work in Snow Leopard, but I can't play multiplayer as none food or materials gets onto the stockpile or granary. It just sits as a list on the left of the screen. I updated it to 1.2 but this didn't help. Many thanks for letting me know that this game worked as it is one of my favourites.

    Charles
     
  12. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #12
    If you go to Lion... the PPC Mac version won't work.

    If you have the Windows version of Stronghold, it works almost flawlessly with Wineskin, so you can port it yourself that way and it will run on Lion fine... but the native Mac version will not work on Lion.
     

Share This Page