Will the 9600 Pro work in OS 9?

Discussion in 'PowerPC Macs' started by Jake0604, Jul 16, 2013.

  1. Jake0604 macrumors regular

    Joined:
    Mar 31, 2011
    #1
    I bought a 9600 Pro to put in my dual 800mhz G4 but when I try to boot OS 9 it doesn't work. Any solutions?
     
  2. rabidz7 macrumors 65816

    rabidz7

    Joined:
    Jun 24, 2012
    Location:
    Ohio
  3. Jake0604 thread starter macrumors regular

    Joined:
    Mar 31, 2011
    #3
    Yes
     
  4. MysticCow macrumors 6502a

    MysticCow

    Joined:
    May 27, 2013
    #4
  5. Jake0604 thread starter macrumors regular

    Joined:
    Mar 31, 2011
    #5
    It can't be that because it runs fine in 10.1
     
  6. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #6
    What OS 9 version? Try 9.2, but you won't get full acceleration and most likely all color depths.
     
  7. MysticCow macrumors 6502a

    MysticCow

    Joined:
    May 27, 2013
    #7
    Well, that's according to AMD/ATI. They said it requires 10.3.6. It's on page 1. If it runs in 10.1, it's unsupported but it will still run or the system is able to recognize it as a graphics card and run it. There is no OS 9 driver for that. Also see http://www.mac-forums.com/forums/ru...1312-os-9-drivers-radeon-9600-pro-pc-mac.html

    The driver doesn't exactly exist for OS 9. The drivers on the driver link may be able to recognize it as a graphics card and run it.
     
  8. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    This doesn't directly answer your question but it might help: The best Apple-shipped card for OS 9 was the GeForce Ti 4600. The best Radeon was the 9000 Pro. Both of these were options on the last OS 9-compatible machine in 2003 (I really regret selling that computer!)
     
  9. Swampus macrumors 6502

    Swampus

    Joined:
    Jun 20, 2013
    Location:
    Winterfell
    #9
    I seem to recall reading a while back that the last ATI Universal Installer (Jan 2005) would help with cards other than what was listed.

    It might be worth a shot? Installer requires updating to 9.2 (If 666sheep is correct, that might solve your problem anyway).

    http://gona.mactar.hu/ATI_Mac/#CS

    I'm surprised that it doesn't work at all. Don't people use their 9800s in OS 9--Just without 3D support?
     
  10. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #10
    Yes; I was able to use a 9800 in 9.2.2 without acceleration.

    Side note: I installed the ATI Universal drivers on a Rage 128 machine and it completely broke rendering in Quake. It's probably best to not install unless you need it :)
     
  11. Jake0604 thread starter macrumors regular

    Joined:
    Mar 31, 2011
    #11

Share This Page