iPhone Will updating to iOS 6 ruin my hacktivation?

Discussion in 'Jailbreaks and iOS Hacks' started by applegeek13, Dec 24, 2012.

  1. applegeek13 macrumors regular

    Joined:
    Sep 7, 2009
    #1
    I jailbroke my iPhone 3GS to bypass the carrier activation, because it was given to me after a friend upgraded and I use it essentially as an iPod touch. The only thing I used the jailbreak for was to bypass carrier activation; I haven't installed any Cydia apps or the like. If I click the "Update" button in iTunes (or Settings on the phone itself) will I need to activate with a carrier? I figure I'll lose the jailbreak, but if the updates sees that I'm "activated", will it just go from that and let me use the thing?
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    Why do you want to update to 6.01?

    depending on how old the 3GS is it will be either a tethered or untethered JB.

    what firmware are you on now and do you have your SHSH/blobs/hashes saved for this firmware?

    as far as i know you can hacktivate your 3GS on 6.01 as well.
     
  3. motulist macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #3

    Agreed. Don't fix what ain't broken. Unless there's some feature in iOS 6 that you specifically want to have, then you shouldn't update. This holds true in general, not just for your specific situation. Don't update just to update. If you're happy with how your phone works right now and there's no specific feature you want in the most recent iOS, then just let sleeping dogs lie.
     
  4. applegeek13 thread starter macrumors regular

    Joined:
    Sep 7, 2009
    #4
    I'd like to upgrade because I'm starting to see more and more apps tell me I need to have iOS 6 for them to be compatible, and I really would like my xkcd app to work. I don't know a whole lot about jailbreaking phones and such, but I can try my best.

    Firmware: Not sure, it says under the Settings>General>About under Version 5.1.1 (9b206)

    The modem firmware in the same section says: 05.16.05

    The model is MC640LL

    I don't know what SHSH/blobs/hashes are saved for it. Or if I have saved any for it. I'm just wondering if updating will brick the phone, force me to activate or bypass with a hacktivation, or if it will work through some miraculous glitch. Perhaps I'll just do a full back up and see what happens when I try it out.
     

Share This Page