Win 10 BootCamp on El Capitan. No Keyboard/mouse :(

Discussion in 'Windows, Linux & Others on the Mac' started by iHateMacs, Oct 19, 2015.

  1. iHateMacs macrumors 6502a

    iHateMacs

    Joined:
    Aug 13, 2008
    Location:
    Coventry, UK
    #1
    Hi,

    I had Windows 8.1 running in BootCamp so I could play GTA V. Everything was going fine.

    I fancied upgrading to Win 10 so I gave it a go.

    The update worked ok and I was using it for a few minutes before I used Apple Software Update to download whatever it downloads.

    Now when I boot up in Windows I see a nice lock screen but I cannot get past it as the keyboard and mouse are not recognised. My mouse does not light up. It does during booting and flashes on a off a few times but stays off once booted.

    If I press the power button on the back of the iMac, windows will shutdown.

    I am using a late 2013 iMac as per my signature.

    Is there a way to fix this without having to remove the partition and install win 10 fresh with bootcamp assistant?
     
  2. brdeveloper macrumors 68020

    brdeveloper

    Joined:
    Apr 21, 2010
    Location:
    Brasil
    #2
    I'll say what solved to me:

    1. Have in hands wired keyboard and mouse;
    2. Start OSX;
    3. Unpair/Remove both Magic Mouse and Keyboard;
    4. Start Windows;
    5. Try pairing the bluetooth stuff. Make sure your devices are in "pairing" mode (i.e. blinking);
    6. Restart on OSX and repair the removed devices.

    The procedure above allowed me to have mouse and keyboard working in both systems.

    If that doesn't work, it may be a driver issue. In this case, I'd extract the Bootcamp drivers and install them one by one. Make sure you're installing the right driver for each device. In my case, I also had to download a Broadcom installer from Broadcom site for having bluetooth properly working on my Mini 2010. Good luck!
     
  3. iHateMacs thread starter macrumors 6502a

    iHateMacs

    Joined:
    Aug 13, 2008
    Location:
    Coventry, UK
    #3
    Thanks for the suggestions, I should have mentioned that the keyboard and mouse are wired already.

    I did try to install drivers to the bootcamp partition from within OSX but I could not get any of the tricks to write to an NTFS drive to work :-/

    The odd thing is, Yesterday I worked fine then after a reboot it didn't. So frustrating.
     

Share This Page