Win 7 install updates issue...

Discussion in 'Windows, Linux & Others on the Mac' started by AFPoster, Apr 3, 2011.

  1. AFPoster macrumors 65816

    Joined:
    Jul 14, 2008
    Location:
    Charlotte, NC
    #1
    I have a 2011 MacBook Pro 15" i7 and I just installed Windows 7 Pro via Boot Camp. Everything works perfect but I am trying to install the 64 updates "Windows Updater" says I need. Every time I check it to update it won't update. Is this because the updates don't work off a Mac or... actually I can't think of any reason.

    Let me know or if there is a work around, thanks!
     
  2. joec1101 macrumors 6502a

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #2
    Mine won't install the Win7 Service Pack 1 - it just constantly fails. I've tried every suggestion I've been able to find, mostly from the SevenForums.com site, to no avail.

    From the litle bit of research I've done, it seems there are issues with Win7 updates with MBP as well as other machines.

    I really think it's a Microsoft issue since it's happening with all different brands of hardware.

    I guess we'll just have to wait for MS to release "fixed" updates. :(
     
  3. AFPoster thread starter macrumors 65816

    Joined:
    Jul 14, 2008
    Location:
    Charlotte, NC
    #3
    Yeah that's unfortunate that we can't get them.
     
  4. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #4
    Weird. All three of my W7 boxes (DIY PC desktop, 2009 MBP and 2008 uMB) installed W7SP1 perfectly via Windows Update.

    Have you tried downloading the update as an ISO?

    B
     
  5. Winni macrumors 68030

    Winni

    Joined:
    Oct 15, 2008
    Location:
    Germany.
    #5
    I've installed a bunch of new Win7 machines over the last days, including Macs, and all installed and updated to SP1 just fine.
     
  6. AFPoster thread starter macrumors 65816

    Joined:
    Jul 14, 2008
    Location:
    Charlotte, NC
    #6
    Hmm... I wonder why it won't let me update then. I left it on the "installing updates" status for like 4 hours and it was still at 0%. I'll try again tonight.
     
  7. AFPoster thread starter macrumors 65816

    Joined:
    Jul 14, 2008
    Location:
    Charlotte, NC
    #7
    I finally got all of the updates, apparently they were downloading in the background even though it was showing 0%. I just needed to shut-down instead of always restarting like I normally do they the updates installed.
     
  8. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #8
    yes this happend to me and was driving me :mad:

    then gave up.. went bed and when i turned on mac in morn and switched to win7/bootcamp - installs worked after the machine was turned off!
     

Share This Page