Win 7 Iphone not being detected correctly after itunes install.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Aetherguard, Oct 24, 2009.

  1. Aetherguard macrumors newbie

    Joined:
    Oct 24, 2009
    #1
    Hi guys, need some expert help.
    I just built a new box with win 7 (x64), and the new intel core i7 800 series processor.

    Before I install itunes, windows detects the iphone correctly, creates the camera icon in my computer like it did before under vista(x32) etc. After itunes it gets detected as an mtp device.

    I have tried uninstall/reinstall ad nausium.

    Force install of the drivers (I get an error that the drivers found in system32, as well as common files\apple are not compatable with this os)

    Install an older version of itunes. All installs are of the x64 variaty.

    all the services are running correctly. It just won't install my iphone as an iphone when itunes is installed.

    edit: I did all of the above with and without media player, center, etc. installed. As I saw that on a forums for win 7 beta. Additionally I tried the uninstall and re-detect trick to no avail.

    I am looking for some insight. I won't have a chance to call apple till maybe next weekend.

    Thanks.
     
  2. Aetherguard thread starter macrumors newbie

    Joined:
    Oct 24, 2009
    #2
    Update: It appears that there is an issue between the Apple usb driver and the Intel P55 chipset (the one that is on all the lga1156 motherboards.)

    I am going to attempt to install a usb card and reportedly that should resolve it. I will update this post again, in case anyone else is planning to upgrade, or whatever.
     
  3. jbs1077 macrumors newbie

    Joined:
    Oct 19, 2009
    #3
    I have problem with iTunes 9 as well on my Windows 7 laptop. I'm still using the RC version and I have used iTunes 8 with my iPhone 3GS without a glitch until I upgraded to iTunes 9. Firstly, every time I plug my iPhone to the laptop it keeps asking for the driver and I have to install them every time. Secondly, I had to authorize my laptop again after I upgraded to iTunes 9 and it turns out that I had used 2 out of 5 authorizations when in fact all along I've only used the same laptop.
     

Share This Page