Win XP does not print via Canon MP970 via Airport Extreme

Discussion in 'Mac Accessories' started by JimTigerPT, Mar 17, 2008.

  1. JimTigerPT macrumors member

    JimTigerPT

    Joined:
    Feb 17, 2008
    Location:
    Baton Rouge, LA
    #1
    OK, I bought a Canon MP970 printer and hooked it up to the airport extreme, changed all of the ports to 10.0.1.1 on my XP, shared the printer, ran Bonjour, ran airport utility, and everything I know how to do. I can print from my Powerbook G4 and from a new black macbook that I just bought on my network. Problem is I cannot print from my windows XP PC. Very frustrating. It did work fine with my HP printer; that is print from my laptops AND my PC desktop. Any help would be greatly appreciated!:mad:
     
  2. JimTigerPT thread starter macrumors member

    JimTigerPT

    Joined:
    Feb 17, 2008
    Location:
    Baton Rouge, LA
    #2
    Solved!

    OK, I kept working at it and seemed to have fixed the problem. I finally just redirected the port to a local one "9101"and not the 10.0.1.1 and began working. I am not sure what I did definitively to make it work. And I just installed the latest printer drivers into my PB G4 and new blackbook and worked. I really just need to trash the PC and go with Apple but you know.......wife.....$$$$$, etc....

    Hope this helps someone else for sure :p
     
  3. Roy43 macrumors newbie

    Joined:
    Nov 18, 2009
    #3
    Go to Security and make sure that the top block "Block all...." is not checked.
    I fought this over and over and the Canon guy finally had me change security setting and then the iMac asked me it allow all the Canon stuff. I did and it all prints now...AFTER about 4-5 hours of trying to figure it out reading on net and talking to Apple support. Apparently the iMac sees the printer in "block all...." but it cant work with it unless securioty settings are changed to allow it to all work together. None of this was required with the HP CP2025 when I installed it on network. Go figure, a lot of this is over my head!
     

Share This Page