Resolved Win7 unable to boot from optibay - blinking cursor - 2012 MBP 13"

Discussion in 'Windows, Linux & Others on the Mac' started by metaxidis, Sep 24, 2012.

  1. metaxidis, Sep 24, 2012
    Last edited: Sep 29, 2012

    metaxidis macrumors newbie

    Joined:
    Aug 19, 2011
    Location:
    Boston USA/ Cyprus
    #1
    First off, it has been a loooong two days.

    Now that I got that out of my system, here's the deal..

    I have a mid 2012 non retina MBP 13", with an intel SSD in the Original drive bay and the original stock Hitachi 500gb drive in the optibay slot.

    After repeatedly failing to install Win7 on the optibay HDD due to an error I got during windows setup (something about not being able to use anydisk for installation ) I decided to remove my OSX SSD and hook up my external superdrive to install windows on the optibay HDD using my original installation disk (and without bootcamp)

    This completed successfully and I managed to get WIN7 to work. Since I installed without Bootcamp,I added it after I booted into WIndows.

    The problems started when I put back my OSX drive.

    Whereas WIN7 would boot perfectly when it was the only drive in the MBP , as soon as I would try booting with my OSX drive connected, I would get a never ending blinking cursor.

    I tried to boot from WIN7 installation disk as well as a system recovery disk but got the same blinking cursor.

    Thus, I disconnected my OSX drive again and booted into WIN7, downloaded EasyBCD and thought to try to rewrite my MBR boot info (sorry if my lingo is wrong, I'm not that advanced).

    But, that did not work.

    I also noticed that I had installed WIN7 on an NTFS drive that used GPT instead of MBR so I used Aomei Dynamic Disk Manager to convert my drive from GPT to MBR hoping that would help.

    Again, It failed.

    rEFIt was no good either

    Swapping the drives didnt help either (putting OSX SSD in optibay and WIN7 HDD to HD Bay)

    At this point I am out of ideas and I'd appreciate any feedback.


    Sorry for the long thread, But I really dont want to have to unscrew my MBP to disconnect the OSX drive everytime I wanna run WIndows


    UPDATE:

    I figured it out but I don't exactly know how. I used disk utility to repair both MAC HD and BOOTCAMP drives and then it just booted into windows with no problem.
     
  2. bubinsk, Nov 3, 2012
    Last edited: Nov 3, 2012

    bubinsk macrumors newbie

    Joined:
    Nov 3, 2012
    #2
    Lucky you! I have exactly the same issue but it won't work! I did everything you explained in your post but with no results. OS X doesn't recognizes the bootcamp partition as bootable and so it doesn't show up in the startvolume preference...
    If I hold down the alt/option key on startup the windows partition shows up as an option but as soon as I start it I get a "no bootable device" error. Diskutility didn't do the trick...

    Can you please explain how you rewrote your MBR bootinfo with EasyBCD, how you checked if your partition is GPT or MBR and how you converted it to MBR?

    I'm also a bit confused about that. I thought Bootcamp emulates an MBR disk because OS X runs only on GPT?

    The drive which sits in the optibay is partitioned for some data for my OS X and the partition for Bootcamp...

    Thanks
     
  3. rocketsheep macrumors newbie

    Joined:
    Dec 20, 2012
    #3
    that worked for me. SSD with ML in Optibay at 6GB and the W7 HDD in mainbay.
     

Share This Page