Winclone - XP partition not seen by MBP

Discussion in 'Windows, Linux & Others on the Mac' started by SimonBishop, May 7, 2011.

  1. SimonBishop macrumors newbie

    Joined:
    May 7, 2011
    #1
    I replaced the HDD in my MBP with a larger one.

    I mounted the new HDD as an external.
    I copied the Mac partition onto the new drive.
    I used Winclone to make an image of the XP partition.
    I installed the new HDD in the MBP.
    I used Bootcamp Assistant to make the NTFS partition, but did not install XP.
    I restored the XP image to the NTFS partition.

    All appeared well, but at the end of the restore Winclone said there had been some errors.

    All my files appear to be in the Bootcamp partition.... BUT

    When I start the Mac whilst pressing the alt key - it only offers me the Mac partition to boot from.

    I am beyond my comfort zone now - does anyone have any clues???

    Many thanks,

    Simon B

    This is from the winclone log.....

    99.99 percent completed
    99.99 percent completed
    100.00 percent completed
    100.00 percent completed
    100.00 percent completed
    100.00 percent completed
    100.00 percent completed
    100.00 percent completed
    100.00 percent completed
    Syncing ...
    return value of "/Library/NTFSProgs/ntfsclone" --rescue -f -f -O "/dev/disk0s3" /dev/disk1 1>&2 is 0

    =====unmounting disk image==============

    /usr/bin/hdiutil detach /dev/disk1
    return value of /usr/bin/hdiutil detach /dev/disk1 is 0

    "disk1" unmounted.
    "disk1" ejected.
    Volume Windows XP on /dev/disk0s3 mounted
    destination_path is /Volumes/Windows XP
    Unmounting /dev/disk0s3
    /usr/sbin/diskutil unmount "/dev/disk0s3"return value of unmount is 0

    =====expanding=====

    "/Library/NTFSProgs/ntfsresize" -f -f "/dev/disk0s3"
    return value of "/Library/NTFSProgs/ntfsresize" -f -f "/dev/disk0s3" is 256

    ntfsresize v2.0.0 (libntfs 10:0:0)
    ERROR(102): Opening '/dev/disk0s3' as NTFS failed: Operation not supported on socket
    The NTFS journal file is unclean. Please shutdown Windows properly before
    using this software! Note, if you have run chkdsk previously then boot
    Windows again which will automatically initialize the journal correctly.
    "/Library/NTFSProgs/ntfsresize" -f -f "/dev/disk0s3" did not complete successfully
    cleaning up: Mounting Disk
    Volume Windows XP on /dev/disk0s3 mounted
    Fri May 6 03:06:42 BST 2011
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    This usually happens because Windows is hibernated or otherwise running before you tried to image it.

    If you still have the original HDD, I would suggest you re-intsall it, boot to Windows. Run CHKDSK /F for completeness and then shut it down completely.

    Then, re-image it and start again.

    Otherwise, ... I may be able to lead you through a process of forcing the steps Winclone would have taken to make the image bootable, but that's no fun.

    B
     
  3. SimonBishop thread starter macrumors newbie

    Joined:
    May 7, 2011
    #3
    Many thanks for your reply...

    I ran chkdsk /f/r twice before making the image.

    I am 99.99% sure that XP was closed down properly, and not running. I tried the image restore twice, first time the box 'if XP detected...' was ticked, and the second time not so.

    Its a 4 hour image, and a 4 hour restore.... so I'd love to avoid that time if possible.

    Many thanks again...

    sb

     
  4. joec1101 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #4
    This is why I don't even bother trying to image a Windows installation anymore. I end up with errors and wasting more time than it would take to just do a clean install.

    Save yourself the headache and just start fresh with a clean install...
     

Share This Page