Windows 10 (or 8.1) on a Mac Pro 1,1...

Discussion in 'Mac Pro' started by iMattux, Jan 1, 2016.

  1. iMattux macrumors member

    Joined:
    Oct 6, 2015
    #1
    Okay, I actually paid for a Windows 8.1 license and figured I could install it using BootCamp in El Capitan on my Mac Pro 1,1 (->2,1 firmware, Pike's EFI... see my sig).

    So far, it's a no-go.

    Here's what I get when I run El Cap's Bootcamp Assistant:

    Screen Shot 2016-01-01 at 12.46.41 AM.png

    Note that there's no option to create media from the ISO image I downloaded. That's what the various links around the web said to do, but they're not running El Capitan on a Mac Pro 2,1...

    I dd'd the ISO to flash drive, but it's not bootable and Bootcamp doesn't see it, it wants a DVD.

    A whole bunch of peeps seem to be running Win 10 with no problems, so please share with me how I can install 8.1 pro and then upgrade to Win 10. Do I have to go get blank DVD's?

    I'm sure it's already here, I just can't find it. I searched for "Windows 10" and dutifully waded thru 23 pages of posts before I asking for some helpful friend to point me to the right post in the right thread.

    TIA
     
  2. VAGDesign macrumors 6502

    VAGDesign

    Joined:
    Feb 1, 2014
    Location:
    Greece
  3. hwojtek macrumors 6502a

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
    #3
    I followed these procedures and it still didn't work on my 2,1 w/upgrades, so I just put my Win hard disk in a regular PC, installed Windows there, put the disk back to the MP, job done.
     
  4. iMattux, Jan 1, 2016
    Last edited: Jan 1, 2016

    iMattux thread starter macrumors member

    Joined:
    Oct 6, 2015
    #4
    Ok, here's my report so far:

    I signed up as a Windows "Insider" (free) to gain access to legit ISO's and downloaded both the 32bit and 64bit Win 8.1 Pro "Enterprise" (?) editions...

    Neither version would boot. I used dcfldd (forensic version of dd with progress - highly recommended homebrew port) to copy them to USB flash drives. The 32bit USB drive shows up in EFI boot screen, but hangs. :(

    I found this page with instructions on how to hack the Bootcamp Assistant plist in El Capitan so the "create installer from ISO" is enabled on 1,1/2,1 MacPros.

    His instructions were pretty close, but I had to make a few modifications - maybe he wrote the post before 10.11.1? Anyway, I booted from my Pikified install partition (I don't have recovery because I have the installer. Either works the same) and disabled SIP first.

    My modified step 1:
    Code:
    sudo cp -p /Applications/Utilities/Boot \Camp \Assistant/Contents/Info.plist ~/Desktop/
    the "-p" argument preserves the files ownership, permissions, modification date, etc. Without "-p" all those attributes change. "-p"=EXACT copy. "cp"=copied by current user and owned by current user, for those who don't know.

    I then opened the Info.plist copy using XCode, added my boot ROM version and model identifiers to the lists as Yiannis instructs, saved the file, verified that ownership and permissions were unchanged and then:
    Code:
     cp -p ~/Desktop/Info.plist  /Applications/Utilities/Boot \Camp \Assistant/Contents/Info.plist 
    overwrites the original Info.plist, verify ownership & permissions, reboot into Installer, enable SIP, reboot and:

    Screen Shot 2016-01-01 at 4.35.53 PM.png

    Tada! "Create Win 7 or later install disk" is enabled on my antique MacPro". :D:cool:

    Unfortunately, the install USB that Boot Camp Assistant created wouldn't boot either. I added the bootIA32.efi from the 32bit installer to the 64bit installer, still no-go...:mad:

    I'm downloading an 8.1 Pro AIO (all-in-one) iso that is one ISO with both 32 & 64bit. I'll give that a try in a couple of hours and report back.

    My brother will be home tomorrow. If this fails, I'll head over to his place and create a DVD on his Windows box.

    Cheers
     
  5. haralds macrumors 6502

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #5
    the best luck I have had is to install from a modified physical DVD.
    Look at it here: http://www.jowie.com/select-cd-rom-boot-type

    I was able to install the latest version of bootcamp by starting an Admin shell and launching the setup.exe with 'start setup.exe'

    From there, I was able to update to Windows 10.

    You might have to run a repair on BootCamp after that.
     
  6. cw48494 macrumors regular

    cw48494

    Joined:
    Jun 17, 2015
    #6
    All I needed to do was boot from windows disk and install just as I would on any normal PC, I had to remove my OSX drive when doing so.
     
  7. iMattux thread starter macrumors member

    Joined:
    Oct 6, 2015
    #7
    Well, I followed those instructions as best I could. I used oscdimg to modify the ISO and then burned it on the PC. I have imgburn, but I don't see the options that Jowie shows. The disks burn & verify without errors, but the MacPro sees them as blank media 3x now...:(:mad:

    Haralds - what do you mean by:
    I have BootCamp 6 (El Capitan default) installed with the modified Info.plist. Boot Camp assistant downloads the drivers and creates the USB installer, partitions the drive and then does not boot from the USB.

    Damnit!
    --- Post Merged, Jan 5, 2016 ---
    Wow, cw48494. Your signature reads like a history of Macs. You have a Sawtooth that still runs OS 9?!? Awesome and LMAO! A museum exhibit of functional 20-30 year old computers would be super cool.
     

Share This Page