Windows 10 Preview using VirtualBox on Mac Pro Early 2008

Discussion in 'Mac Pro' started by mtm5062, Mar 24, 2015.

  1. mtm5062 macrumors newbie

    Joined:
    Mar 24, 2015
    #1
    Can this be done? I want to use Virtualbox rather than Boot Camp because Windows 10 is still in the beta phase. I have been trying for awhile with zero success. I keep getting error:

    "Failed to open a session for the Virtual Machine Windows 10.
    Failed to load VMMRO.R0
    (Verr_SUPLIB_OWNER_NOT_ROOT)

    Result Code: NS_ERROR_FAILURE (0x80004005)
    Component: Console
    Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

    Please help and let me know what I am doing wrong. I am pretty sure this can be done but I am stuck. I have tried with older versions of VirtualBox and using different ISO files and keep getting errors.

    Specs:
    OS X Yosemite version 10.10.2
    Mac Pro Early 2008
    Processor 2x2.8 GHz Quad-Core Intel Xeon
    Memory 4 GB 800 MHz DDR2 FB DIMM
    Startup Disk ProMax 1 TB
    Graphics ATI Radeon HD 2600 XT 256 MB


    Thanks
     
  2. IowaLynn, Mar 24, 2015
    Last edited: Mar 24, 2015

    IowaLynn macrumors 6502a

    IowaLynn

    Joined:
    Feb 22, 2015
    #2
    This looks like a nice how to guide. Also this came up with Google search .

    This Bing and this linked article: search result on Virtualbox forum looks promising.

    Finally after examining Virtual Box log files i saw that it complains that /Applications folder is not owned by root... a "sudo chown root /Applications" fixes the problem
    It came from https://www.virtualbox.org/ticket/7889

    ----------
    On a side note, I would double the memory more for Yosemite as well as upgrade GPU as 10.10 would probably like to see a more modern card.
     
  3. sarthak macrumors 6502

    Joined:
    Nov 19, 2012
    Location:
    Canada
    #3
    If you just need it for a short period of time, try a trial version of VMware Fusion 7 Pro and consider buying it if it works for you.

    Works fine on my end in Fusion 7 Pro except features like Unity.
     
  4. mtm5062 thread starter macrumors newbie

    Joined:
    Mar 24, 2015
    #4
    Fixed

    Thanks for all your help. I just had to run Disk Utility and Verify the Permissions on my main hard drive. After that I rebooted, tried VB again and got no errors and it is working as it should.

    Thanks,
    Mac
     

Share This Page