Windows 10 tablet not recognizing USB3.0 to SATA adapter

Discussion in 'Alternatives to Mac Hardware' started by dantastic, Feb 21, 2017.

  1. dantastic macrumors 6502a

    dantastic

    Joined:
    Jan 21, 2011
    #1
    I just bought a cheapo Windows 10 tablet with a full size USB3.0 port hoping I would be able to copy footage from sd cards over to a USB HDD. I have a whole bunch of 2.5" drives around so I bought a USB3.0 to SATA adapter.

    The adapter is a powered adapter to ensure the spinning rust always have enough juice.
    The adapter is working at full speed on my MBP.

    When plugging it in directly into the windows tablet the device is not recognized in the device manager at all. If you unplug and replug you may get a message saying the USB device failed and Windows couldn't understand what it was.

    I have tried attaching through other USB3.0 hubs with the same result.
    I have tried re-installing the driver.
    I have tried disabling power management for the usb and the usb mass storage device.

    I have also tried using a USB2.0 hub - And it works!!
    I understand the controller is different (or it's just a driver, isn't it?) between 2.0 & 3.0.
    The device is working perfectly on 2.0 (just not as fast) so it appears all the hardware is OK.

    Any idea how I can get this to work on USB3.0 as well??
     
  2. keysofanxiety, Feb 21, 2017
    Last edited: Feb 21, 2017

    keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Apologies if you've already tried this when you said you reinstalled the driver! Please can you plug in the device, open Device Manager (Windows + R, devmgmt.msc), then expand Universal Serial Bus controllers. Right-click every single one in turn and select Uninstall. If you have the option to delete driver software, be sure to check this too.

    Then restart the computer after you've uninstalled every single USB driver, whilst leaving the adapter still plugged in. Just a gentle reassurance that this won't do any damage whatsoever to the machine and won't mess up anything down the line. Hopefully this will now work! :)

    EDIT: If that doesn't work, you can also try the following. It doesn't work on Surfaces but may on other tablets. Press Windows + R and type powercfg.cpl. Ensure that the system is on High Performance mode. Then click Change plan settings> Change advanced power settings> USB settings>USB selective suspend setting, and ensure this is disabled.

    If that doesn't work, go back to powercfg.cpl again. Click Choose what the power button does along the left hand side. Select Change settings that are currently unavailable, then scroll down and untick Fast Startup (recommended). Restart the computer again. Any better?
     
  3. dantastic thread starter macrumors 6502a

    dantastic

    Joined:
    Jan 21, 2011
    #3
    Thank you for your response. I tried removing the drivers like you mentioned. The same ones are reinstalled after. Can you get "better" drivers from somewhere else manually perhaps??

    I have some cheapo tablet and none of those power options are available. I have resorted to manually disabling the USB power saving in the registry though so I hope that will have the same result.

    It's a Intel USB 3.0 eXtensible Host Controller - 1.0. I'll see if I can find a different driver...
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Try download/scan for driver updates through Intel Driver Update Utility: https://downloadmirror.intel.com/24345/a08/Intel Driver Update Utility Installer.exe

    The USB drivers are pretty generic so no alternate places to get them from. Also are you on the anniversary edition of Windows 10? You can quickly verify this by pressing the Start menu. If it says 'Settings' rather than just showing a cog icon, it's not on AE.
     
  5. dantastic thread starter macrumors 6502a

    dantastic

    Joined:
    Jan 21, 2011
    #5
    I'm fully up to date.
    I've tried to d/l the driver from Intel direct but it won't install. I'll try the tool you linked now.
    Apparently, this is a common issue with the USB3 chipset. Several manufacturers affected. There seems to be some hacks available but it is a driver issue.
    I'll just keep trying different drivers.
     

Share This Page