Windows 7 and Snow Leopard File Sharing - Can't Get It to Work

Discussion in 'macOS' started by exFictitiouZ, Oct 3, 2009.

  1. exFictitiouZ macrumors newbie

    Joined:
    Oct 3, 2009
    #1
    I've been scratching my head for the past few days, figuring out how to get files properly shared between Mac and Windows.

    Things used to be simple with Leopard and XP, with the network browser working seamlessly like magic, detecting the XP within few seconds after it connected. But that's no longer the case. Since I upgraded XP to 7, automatic detection of the Mac side was going on and off, and folder access was also on and off, somewhat unreliable. Then I upgraded from Leopard to Snow Leopard, the automatic detection is completely gone, complete reliance on cmd+k now, and something strange happened . . .

    I've figured out how to share Mac files with Windows, and it is working properly on the Windows side. The problem is the other way round, where I can get only some Windows folders shared and not some others. The settings are exactly the same, and that brings me to a dead end.

    To explain the situation, here are some screenshots:
    I typed the local IP address of the Windows PC, and I could see 2 folders are shared, which are 'Users' (sharing automatically preset, I didn't set this one up) and 'Hoshi' (which I set the sharing up, and it is an entire partition, not just a folder). Strangely enough, I could access the 'Users' folder:
    [​IMG]

    but not the 'Hoshi' folder. This message popped up when I try to access the folder via its directory in Finder (exFictZs-PC from sidebar, then the folder itself)
    [​IMG]

    And I got the message if I try mounting the folder at authenticating step:
    [​IMG]

    However, if I check the permissions on the Windows side, they show the same settings:
    [​IMG]

    Any ideas ? :confused:
    Thank you in advance
     
  2. JessicaD macrumors newbie

    Joined:
    Jun 3, 2009
    #2
    exFictitiouZ,


    Thank you for evaluating Windows 7! Just so you are aware Microsoft does have an official Windows 7 Support Forum located here http://tinyurl.com/9fhdl5 . It is supported by product specialists as well as engineers and support teams. You may want to check the threads available there for additional assistance and feedback.

    Jessica
    Microsoft Windows Client Team
     
  3. Doc69 macrumors 6502

    Joined:
    Dec 21, 2005
    #3
    Did you ever get it to work? I haven't been able to make it work either way.

    If you could tell me how you got the PC to see the Mac, I would appreciate it.
     
  4. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #4
    Welcome to my hell. I had it running perfectly with full guest privs and of course I upgraded from RC to windows 7 professional, ugh. Well not an upgrade, a clean install which also nuked my perfectly working system. All I want to do is share one folder with full access, guest privs, etc. So far I have setup the share with full access for "Everyone" and for "Guest." And I also setup security access to that folder for "Everyone" and for "Guest." I also screwed around with the settings in the control panel to allow for no password access. I have the homegroup crap turned off, as I did before. Don't know what else to do. I hate hate hate hate both windows and mac networking. Why can't either of these companies get networking right.

    EDIT: Tried this little solution, not a thing. http://social.technet.microsoft.com...g/thread/b2560a0d-1602-4bc5-ae35-10fa7ed0b33d
    Also tried giving acces to "Guests" in addition to "Guest" and no luck. Here is the error I get.
     

    Attached Files:

  5. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #5
    As for solutions this is all I've found so far.
    http://osx86install.blogspot.com/2008/05/smb-this-file-server-does-not-allow.html
    http://labs.boulevart.be/index.php/...ow-guest-access-on-os-x-leopard-the-solution/

    I have no clue how to edit the SMB config file on windows. And I can't actually tell if this is a Mac problem or a windows problem.

    EDIT: FIXED IT! I originally went into Advanced Sharing Properties and turned off the "only allow users with a password to connect" option and somehow that got turned back on. I turned it off again, without rebooting this time and my Mac connected just fine.
     
  6. Popple3 macrumors newbie

    Joined:
    Jun 7, 2009
    Location:
    Longford, Ireland
    #6
    I've figured it out! You need to add permissions to Everyone under the Sharing tab AND the Security tab, then just connect as Guest and it works :D
     
  7. steverunner macrumors newbie

    Joined:
    Dec 23, 2008
    Location:
    UK
    #7
    As its a related matter thought I would post here.

    I've loaded Windows 7 on my main PC which has a USB printer attached. I am now unable to see this printer from my Macbook Pro. Worked fine under XP.

    I posted the above in the Windows 7 forums - no answers.

    Anyone got printing working from Mac to PC under 7?

    Steve
     
  8. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #8
    can one view say my mb while on my pc?

    so far, i can only view my pc on my mb
     
  9. arachn1d macrumors member

    Joined:
    Jun 7, 2006
    #9
    I'm having the SAME exact issue and I can't figure out what to do at this point. Anyone have any pointers? I don't see the "allow sharing with passwords" thing on Windows 7? I guess they changed how it looked? I don't have a security tab.
     
  10. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #10
    You're telling me that if you right click on your share folder and select properties that there's no security tab there? :confused:
     

Share This Page