Windows 7 - Device Driver issue

Discussion in 'Windows, Linux & Others on the Mac' started by ebutterw, Aug 2, 2010.

  1. ebutterw macrumors newbie

    Joined:
    Aug 2, 2010
    #1
    Hi - have only just started the journey of installing a VM on my iMac and have hit what looks like a common problem but I cant see a common answer!

    I've got an iMac running OS X (10.6.4 to be precise) with a 3GHz Intel Core 2 Duo processor, 4GB RAM and 500G HDD.

    I installed Parallels 5 preferring it over bootcamp because you can switch over without having to reboot.

    I've then download Windows 7 64bit version from the Microsoft store and run through the installation / creation of a new vm in parallels.

    All seemed to be fine for the first 45 seconds but then I've hit a pop up called "Load Driver" saying "No device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK" - on clicking OK out of that pop up - I have a choice to BROWSE, RESCAN to find the right "driver".

    My question is - what is the right driver? what device is the driver needed for? I've searched around and most suggestions point towards going into device manager - well - I'm still on STAGE 1 of the install of Windows 7 where it says its "Collecting information".

    When I downloaded Windows 7 from the Microsoft store it provided 2 files:

    Windows7_Professional_ISO_64bit.iso and
    bootsect.exe

    but no other files. I stored it in Documents/Windows7 files.

    Apologies if you've had this question a thousand time but could someone kindly suggest how I find out what device drivers I need?

    thanks, Ed
     
  2. confusedxx macrumors newbie

    Joined:
    May 4, 2009
    #2
    Same problem for me with Parallels 6.0 which I am using as trial version right now. There seems to be no fix that is out there for this - at least google does not show me one and neither does the Parallels website.

    Anyone with advice?



     
  3. Grannyville7989 macrumors 6502a

    Grannyville7989

    Joined:
    Aug 2, 2010
    #3
    At what stage of the installation does this happen? Is it when you're about to pick the location of where to install?
     
  4. confusedxx macrumors newbie

    Joined:
    May 4, 2009
    #4
    It happens once you have the VM window open and it needs to start the installation. Seems it cannot find the install files from an image on my hdd or usb or the dvd drive.
     
  5. Grannyville7989 macrumors 6502a

    Grannyville7989

    Joined:
    Aug 2, 2010
    #5
  6. ubicomp macrumors newbie

    Joined:
    Nov 10, 2012
    #6
    This is what worked for me

    I had the exact same problem, searched everywhere, and only found one obscure little post somewhere that was my key to fixing this problem. I have a MBP Mid 2010 15" Core i7. Clean install of Mountain Lion on a brand new Crucial M4 SSD. I ran Bootcamp, followed instructions to the "T" as everyone on the forums with their RTFM responses so helpfully points out (sarcasm). I downloaded the drivers to a USB key, had my Win7 x64 install disc in the drive. Bootcamp would auto-reboot after creating the partition on my SSD, Win7 would start to install, I would get a couple steps in and get the message " no device drivers found make sure that the installation media...blah blah". I tried browsing to the USB key, which the installer could see, selected the folder on the key with the files. Every time, some message to the effect of "could not find files". No matter what, it would not find the files on the key, even though the files where clearly there. Then I tried the rEFit bootloader approach, that was a waste of time. Many searches to many different boards with no help, except for one which mentioned using a good hi-speed USB and an install disc that was BURNED AT 4X SPEED. I had tried everything else (including using a Win7 USB key install) with no results, so I took a step back, reburned my Win7 ISO onto a new DVD at 4x speed on my PC, verified it after burn. Used my best LaCie USB key (the ones that look like actual keys). I re-ran Bootcamp for about the 20th time. I re-did the step to download the Windows drivers to a USB key.

    This time the install just worked, no problems at all. Win7 install got past the point where it was barking for missing drivers to the screen where it asks which partition on which to install. I selected the BOOTCAMP partition. You have to reformat it first in the installer to be the correct format. Then the install went off without a single hitch.

    So to recap:
    1) Use a decent USB key
    2) Burn your Win7 install disc at 4x write speed, verify it to make sure it's perfect.

    Not sure which one of these two things fixed my "missing driver" issue and allowed a smooth install, but one or both of them did because that's all I did differently this time.
     

Share This Page