Windows 7 File Shares not showing all files

Discussion in 'macOS' started by puntloos, Apr 17, 2011.

  1. puntloos macrumors newbie

    Joined:
    Apr 17, 2011
    #1
    Previously, I ran Windows XP on my home media server/player, and my OSX laptop could easily browse its shares without issue.

    I upgraded XP to Windows 7 Ultimate and:
    - My server doesn't automatically pop up in finder anymore (in the left-hand bar a 'network' icon used to pop up listing my server). Not a massive deal but I figured I'd mention it.
    - Suddenly, swaths of files disappear out of the folders. Some but not all files are there, and I say swaths since it seems to be a bit 'alphabetic'. I got files starting with c, and da-de but not df-e..

    Extra investigation:
    - When I create a temp folder on the server and move the files I want to see into it, everything works, so it doesn't have to do with the actual files or their names.
    - Using another Win7 machine to browse the same shares has no such problems.
    Elp?
     
  2. puntloos thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #2
    Tiny update:

    - No luck with Adobe Bridge or PathFinder, so it's not finder itself, more likely the kernel SMB stuff. Is there perhaps a way to tinker with mounting options, and if so, do any work?
     
  3. puntloos thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #3
    Update:

    As it turns out, others have experienced the same issue with other hardware (Boxee) so this is likely Microsoft who somehow broke their software stack.

    Perhaps someone can find a 'compatibility switch' in Win7 that fixes things?
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Some people in the Apple discussion Snow Leopard 10.6.4 not showing Windows 7 Machines on Finder's Shared. It might be worth a look.
     
  5. samdu macrumors newbie

    Joined:
    May 23, 2011
    #5
    I was Googling around for this same issue, found this thread, checked out the link on the Apple Support page and it wasn't exactly describing the same issue. But I did find a solution. A thread on another board mentioned that it might be an issue with Avast anti-virus on the Windows 7 box. If you're running Avast, do a manual program update (right click the icon in the system tray, select "Update ->" and choose "Program." Let it update and reboot when it requests it and it should be good to go. Worked on my machine. I can see everything on my Win7 box again from my MacBook.
     

Share This Page