Windows 7 installation hangs on "Completing Installation"

Discussion in 'Windows, Linux & Others on the Mac' started by talas43, Mar 24, 2011.

  1. talas43 macrumors newbie

    Joined:
    Mar 24, 2011
    #1
    I've got a 2010 Macbook Pro 13" and I'm attempting to dual boot with Windows 7 64-bit Home Premium on a 250gb partition. The problem is, I can't get it to install. Evey time it hangs on the "Completing Installation" phase after the reboot and from what I can tell, everything but the CPU fan stops. I've looked around and tried everything.
    If I press shift+F10 during that and type 'explorer.exe' (this was a recommended fix), it brings up a box that displays "setting up personalized settings for windows desktop updates."
    I have tried taking out RAM until I have 2gb left, doesn't help. I don't have anything other than the power cable connected. Does anybody have any ideas? Thanks.
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
  3. Patrick946 macrumors regular

    Joined:
    Jun 21, 2009
    #3
    I had this same issue, I tried installing Windows 7 several times (updating from XP on a 13" 2010 MBP), and each time it would get to "Completing Installation" and then freeze. Various threads around the internet pointed out that you could fix the issue by updating your video card drivers, but the drivers were already completely up to date.

    It turns out that drivers are the issue, but since you can't update them the solution is to uninstall them! Go to Add/remove software and choose the one labeled "Nvidia drivers" or something like that and uninstall them altogether. The screen reverted to a way lower resolution, and the found new hardware wizard went crazy, but it let me install Windows 7 with no issues.

    Anyway, I hope that this helps someone who is having the same issue.
     
  4. xpolicy macrumors newbie

    Joined:
    Jul 10, 2008
    #4
    If this doesn't work for you I have another solution that worked for me. This sounds completely dumb but I ended up connecting a external USB keyboard and mouse. When it got to the install part after the first reboot I made sure the mouse was constantly moving and the I was pressing a key on the keyboard at the same time. For what ever reason if I kept the input going on both it finished with the install.
     

Share This Page