Windows 7 is not booting, i can only see black screen with blinking cursor!

Discussion in 'Windows, Linux & Others on the Mac' started by skbharadia, Apr 27, 2011.

  1. skbharadia macrumors newbie

    Joined:
    Apr 21, 2011
    #1
    hello there,

    I had tripple boot MBP 13 inch model, n all three OSs were working great on the machine, but i wasn't using linux that much so decided to remove the partition and have only two - OS X n Windows 7, i removed the linux partition with Disk Utility, and firs time it didn;t go right, so i simply restarted the mac n did it again, and it went through fine.

    Next time when i wanted to boot into Windows 7, surprisingly it only came up with black screen n a blinking cursor on left upper corner, i waited long, hoping to load the windows 7, but it didn't. N since then its bugging me.

    I need to use some programs on windows, and i prefer to use windows natively via boot camp.

    Can any one suggest, what could be the problem and how to sort this issue out?

    Thanks
     
  2. MacHamster68, Apr 27, 2011
    Last edited: Apr 28, 2011

    MacHamster68 macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #2
    i guess thats your problem ---->rEFIt which needs to be installed when using linux via bootcamp and it alters the EFI and the MBR , so by just removing the linux partition you caused a bit of a chaos
    removing rEFIt might sort your problem now if you are lucky ..but i doubt that
    http://refit.sourceforge.net/doc/c1s3_remove.html
    if unlucky a clean install of OSX and windows7 might be your only option and then just use your backups ,timemachine and whatever you used to backup windows..
     
  3. skbharadia thread starter macrumors newbie

    Joined:
    Apr 21, 2011
    #3
    Well, thats sounds bad, but i can boot MBp into mac, n it runs fine, its jst windows is not booting up.

    So, is there no way i can get my windows back?
     
  4. skbharadia thread starter macrumors newbie

    Joined:
    Apr 21, 2011

Share This Page