Windows 7 Mac 10.5.8 and Refit

Discussion in 'Windows, Linux & Others on the Mac' started by P0CKS, Jun 13, 2011.

  1. P0CKS, Jun 13, 2011
    Last edited: Jun 13, 2011

    P0CKS macrumors newbie

    Joined:
    Jun 13, 2011
    #1
    Ok so Im at my wits end, nobody seems to have quite the same issue as me, and after 4 FULL days of researching I just dont know who to turn to anymore.
    Macbook Pro (early 2008) OSX 10.5.8 with Bootcamp Assistant 2.0
    Trying to install a legit copy of Windows 7 (64 bit). Downloaded via school website.
    (as students we get free copies of Windows 7, XP, and Vista all 64 bit though)
    Problem:
    First my optical drive on my mac is not working at all, just spits disks out. Used to be that a pram reset would fix it, not anymore.
    Solution:
    Got an external optical drive via USB (LG)

    Used Bootcamp assistant to create partition for windows, 35 GBs
    Burned the Windows 7 ISO on a pc with Image Burner.
    After clicking the install it went blank, but didn't start the windows installer, instead it took me to the dreaded cant find bootable disk black screen.
    Found out that it may be because the external drive is connected via usb, and apparently drivers are needed to find them first.
    Solution:
    Downloaded and installed reFit
    Restarted via refit. Saw windows cd icon. Clicked and got taken back to the dreaded black screen. ugh.
    After a few tries decided to try something else
    Install via USB
    Blanked my 4gb stick, Used the Windows 7 USB/DVD tool to make it bootable.
    Selected my Windows 7 ISO as source.
    Problem:
    Copied the files fine, except I got an error saying it couldn't make it bootable or something. Dont know why.
    Refit saw it but needless to say black screen appeared again.

    Tried it with my external drive with a partition just for that, no go.
    Burned another cd using the Windows 7 USB/DVD tool, no errors...but again black screen.....
    I just dont know anymore, Ive tried everything I could find.......help (T^T)
     
  2. Xgm541 macrumors 65816

    Joined:
    May 3, 2011
    #2
    I just posted this in a different thread, to make your USB drive bootable, you could follow this guide rather than the windows 7 USB software, its crap.

    http://forums.macrumors.com/showpost.php?p=12747144&postcount=3

    as a note - for god knows what reason, if your external usb drive is not the grossly overprices $79 apple branded one, you probably wont be able to boot from it.
     
  3. P0CKS, Jun 13, 2011
    Last edited: Jun 13, 2011

    P0CKS thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #3
    Thank you very much for your reply. However I am running into some problems.
    When typing bootsect /nt60 L: (my drive) I get the error
    'bootsect' is not recognized as an internal or external command, operable program or batch file
    I used the windows 7 cd that I burned using the windows usb/dvd download tool, Ill try it with the cd I burned with ImgBurn.

    Oh wait, I just looked, the DVD is in the E: drive. Ill try it with that first.
    Edit
    Found it but now I get this error
    This version of e:\boot\bootsect.exe is not compatible with the version of Windows you're running. Check your computer's system information to see wether you need a x86 <32-bit> or x64 <64-bit> version of the program, and then contact the software publisher.
    The pc I am trying this on is Windows Vista 32 bit
     
  4. Xgm541 macrumors 65816

    Joined:
    May 3, 2011
    #4
  5. P0CKS thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #5
    I extracted the file to the desktop, however I got an error trying bootsect, Im not sure if I misunderstood your directions but this is what I did.
    I started from step one, partitioning the usb and all since it already had the previous failed windows, and to make sure I had a clean slate.
    After it was done I started with
    cd desktop
    bootsect/n60 k: (new drive letter)
    Messages received were
    Target volumes will be updated with BOOTMGR compatible bootcode

    Could not map drive partitions to the associated volume device objects:
    Access is denied.

    To clarify it is in an admin account

    Also thank you very much for your help so far :)
     
  6. Xgm541 macrumors 65816

    Joined:
    May 3, 2011
    #6
    right click, click on "Run as administrator" and it will work.

    welcome to windows :)
     
  7. P0CKS thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #7
    Yup thats what wouldn't let me boot sect. But instead of using the 32bit windows bootsect I was able to borrow my brothers which had Windows 7 64 bit. Everything was going well, set it up successfully, and then just dragged and dropped all of the files from the cd to the drive...but then it happened, the No bootable device screen.
    _| ̄|○ .... I don't know what could possibly be the issue anymore. Could I be missing some kind of driver? I've checked my firmware upgrades though, they're all up to date...
    Am I doomed? (˚ ロ˚)ノ
     
  8. Xgm541 macrumors 65816

    Joined:
    May 3, 2011
    #8
    make sure you are using rEFIt. Plug in the USB adapter restart or power on your machine and on the refit screen you should see a second icon with a windows logo and a little usb drive next to it.

    Do you get this kind of screen when booting up? (without the linux, of course..)

    http://refit.sourceforge.net/screen.html

    if not, you may not have refit properly installed.
     
  9. P0CKS thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #9
    Yup, im sure refit is properly installed, and it detects the windows bootable usb too, it just wont carry on with the rest of the operation. I think my only choices now are to try it from internal partitions or bite the bullet and get a new superdrive installed.....a month after applecare expired and everthying goes to hell =___=
     
  10. P0CKS thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #10
    Might be the problem

    I have a question. My bootcamp partition is fat32, as done automatically by bootcamp, But my bootable Windows 7 USB is NTFS (done in a windows machine). Would making it Fat32, make a difference?
     
  11. Xgm541 macrumors 65816

    Joined:
    May 3, 2011
    #11
    i doubt it because the installation of windows 7 will have you format the drive into ntfs anyway.
     

Share This Page