Windows 7 on Late 2015 iMacs?

Discussion in 'iMac' started by mistamarko, Nov 2, 2015.

  1. mistamarko macrumors newbie

    Joined:
    Nov 2, 2015
    #1
    I keep finding mixed information on whether this is possible. I just got a Late 2015 iMac, and BootCamp says it only supports Windows 8 and higher. I wasn't sure with some sort of software, version, etc, if this would be possible. According to Apple's site, it says Windows 7 still works on the Mid 2015 Macs, I guess this is the first edition for it not to?

    If this is TRUE, can I still use Windows 7 with Parallels?
     
  2. iemcj macrumors 6502

    iemcj

    Joined:
    Oct 31, 2015
    #2
    Why are you wanting to still use win 7 when you can go to 10 for free? Pirated copy perhaps?? ;)
     
  3. mistamarko thread starter macrumors newbie

    Joined:
    Nov 2, 2015
    #3
    Perhaps I may soon, but it's only because I'm using an old version of Sony Vegas Pro that I'm unsure works with Win10. Plus, I have the install disc.
     
  4. iemcj macrumors 6502

    iemcj

    Joined:
    Oct 31, 2015
    #4
    Hmm. Honestly man I'd just try it. Download the iso from microsofts website, make your bootable flash drive, and see if your sony vegas pro works. Worst case scenario you waste an hour playing around haha
     

Share This Page