windows 7 on macbook pro, long boot times problem help

Discussion in 'MacBook Pro' started by maxspeed017, Nov 19, 2009.

  1. maxspeed017 macrumors newbie

    Joined:
    Nov 19, 2009
    #1
    hello guys, i just installed windows 7 on my macbook pro. I deleted all the mac os x partition and just installed windows by itself. Everything works fine but it takes a real long time to boot up windows because t kinda stays locked at th start with a blinking cursur for about a minute. Then windows starts to boot up. Anyway to take off the blinking cursur at the start off and just make windows boot right away.
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    I don't want to make the accusation but you're probably running a pirated version of Windows 7. It stays at the blinking cursor for a bit because it's doing things in the background to bypass Windows 7 activation.
     
  3. Ice-Cube macrumors 6502a

    Ice-Cube

    Joined:
    Jul 27, 2006
    Location:
    Somewhere over the rainbow
  4. AnDi86 macrumors 6502

    Joined:
    Jan 15, 2007
    Location:
    Ballymoney N.Ireland
    #4
    hahaha caught out... though you have to wonder why I stumbed across this thread too.... :eek:
     
  5. davidcmc macrumors 6502

    Joined:
    Nov 5, 2009
    #5
    Lol. I've got the same situation here. :D
    Before Windows 7 starts to boot, there's a white "_" blinking for about 30 seconds on a black screen.
    Yea... I think I know what's causing that. :rolleyes:
     
  6. macrmf macrumors newbie

    Joined:
    Aug 15, 2009
    #6
    Yes it is related with windows 7 activation. You have to make changes to your boot sector.
    Pretty sure it is against guidelines to talk more on this subject, but a solution is out there.
     
  7. littleasian macrumors member

    Joined:
    Jun 20, 2009
    #7
    whether you have a pirated copy or not, previously apple had not released full comptability drivers for win 7. even with a legitimate version you would still see a blinking cursor.

    as far as i know, apple released official windows 7 boot camp drivers a few days ago so search those and install them and see if that gets rid of your flashing cursor.
     
  8. SolRayz macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #8
    You will need to run something called A.I_7E.exe...thats all I'm sayin...o and f microsoft.
     
  9. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #9
    You would still get the blinking cursor but it only shows briefly before actually getting to the Windows load screen (Windows Logo). The timing is actually significant - legit being a few seconds, pirated being up to a min or more. Windows 7 drivers have nothing to do with the loading process and even that, it was to fix the red light/audio issues and the trackpad (maybe AirPort) but other than that, everything else was working.
     
  10. GeekOFComedy macrumors 6502a

    Joined:
    Sep 29, 2008
    Location:
    Ireland
    #10
    Not that i support piracy and shouldn't be helping try enable multi core booting in MSCONFIG.
     
  11. Dozerrox macrumors 6502

    Joined:
    Dec 23, 2009
    Location:
    Exeter
    #11
    It's best to leave that setting alone. The computer will boot with both processors anyway. That's a dodgy tip in a lot of faster boot guides.
     
  12. nlr macrumors 6502

    Joined:
    May 27, 2010
    Location:
    London
    #12
    I get this problem too and I would like to fix it, can anyone help me?
     
  13. tombilske macrumors member

    tombilske

    Joined:
    Jan 31, 2010
    Location:
    Australia
  14. skate71290 macrumors 6502a

    Joined:
    Jan 14, 2009
    Location:
    UK
    #15
    Ha! Caught out big time, but the file posted above is the cure... it's nothing to do with Activation it's the BIOS that's messed up, occurs on some, but not all Macs, my idiot parent's bought the software and it still happened :p
     

Share This Page