Windows 7 on USB boot on 2009 Macbook Pro but not 2010 iMac?

Discussion in 'Windows, Linux & Others on the Mac' started by potato.hk, Oct 24, 2011.

  1. potato.hk macrumors newbie

    Joined:
    Jul 22, 2009
    #1
    Hi,

    I tried to install a copy of Windows 7 by using rEFIt and NT6.x Fast installer on an external USB hard disk.

    After NT6.x Fast installer finished copying and modification files on USB hard disk's NTFS partition, I try to boot it from my iMac (2010 -27" i7 Core) but it showed following and stopped:
    "no bootable device insert boot disk and press any key"

    I plugged the same USB hard disk to my macbook Pro (2090 - 17"), it found and booted from NTFS partition and continue the installation. After installation, I could also boot Windows 7 from USB hard disk from my Macbook Pro.

    If I plug this Windows 7 installed USB hard disk to my iMac, it can't find the Windows 7 partition again. (It works again if plug to Macbook Pro.)

    I am completely loss because I don't expect this difference.

    I wonder if someone can help to finger out what is wrong.
     
  2. potato.hk, Oct 24, 2011
    Last edited: Oct 24, 2011

    potato.hk thread starter macrumors newbie

    Joined:
    Jul 22, 2009
    #2
    More detail on Installation of Windows 7 on USB Disk

    I post more detail on what I did.

    I make 2 partitions on my USB disk. First partition is a small one (30G) for install Mac OS and eEFIt and the second one (290G) is for FAT.

    Then I installed Mac OS and eEFIt on first partition.

    Then I ran a copy Windows 7 virtual machine running on vmfusion. I formatted the FAT to NTFS. Next, I ran NT6.x fast installer to prepare the USB Disk for Windows 7 installation.

    After the preparation, the USB disk can be booted on Macbook Pro for continuing the installation but my iMac complained no bootable device.

    After installation, the USB disk can be booted on Macbook Pro but iMac still complained no bootable device.

    Ps. My Macbook Pro is running Lion and my iMac is running Snow Leopard. I tried to install Windows 7 Ultimate - 64 bit version
     

Share This Page